Novell Home

CVE-2012-2113

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2113 at MITRE

Description

Multiple integer overflows in tiff2pdf in libtiff before 4.0.2 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted tiff image, which triggers a heap-based buffer overflow.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entry: 767852, 854393

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CORE 9 for AMD64 and Intel EM64T
  • libtiff >= 3.6.1-38.56
  • libtiff-32bit >= 9-201206221419
  • tiff >= 3.6.1-38.56
Builds
YOU Patch Nr: 12892
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • libtiff >= 3.8.2-5.28.1
  • libtiff-devel >= 3.8.2-5.28.1
  • tiff >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • libtiff >= 3.8.2-5.28.1
  • libtiff-32bit >= 3.8.2-5.28.1
  • libtiff-devel >= 3.8.2-5.28.1
  • tiff >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for x86
  • libtiff-devel >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
  • libtiff-devel >= 3.8.2-5.28.1
  • libtiff-devel-64bit >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for X86-64
  • libtiff-devel >= 3.8.2-5.28.1
  • libtiff-devel-32bit >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SUSE Linux Enterprise Server 10 SP4 for IPF
  • libtiff >= 3.8.2-5.28.1
  • libtiff-devel >= 3.8.2-5.28.1
  • libtiff-x86 >= 3.8.2-5.28.1
  • tiff >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • libtiff >= 3.8.2-5.28.1
  • libtiff-64bit >= 3.8.2-5.28.1
  • libtiff-devel >= 3.8.2-5.28.1
  • libtiff-devel-64bit >= 3.8.2-5.28.1
  • tiff >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • libtiff >= 3.8.2-5.28.1
  • libtiff-32bit >= 3.8.2-5.28.1
  • libtiff-devel >= 3.8.2-5.28.1
  • libtiff-devel-32bit >= 3.8.2-5.28.1
  • tiff >= 3.8.2-5.28.1
Builds
ZYPP Patch Nr: 8199
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • libtiff >= 3.8.2-5.36.1
  • libtiff-devel >= 3.8.2-5.36.1
  • tiff >= 3.8.2-5.36.1
Builds
ZYPP Patch Nr: 8721
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • libtiff >= 3.8.2-5.36.1
  • libtiff-32bit >= 3.8.2-5.36.1
  • libtiff-devel >= 3.8.2-5.36.1
  • libtiff-devel-32bit >= 3.8.2-5.36.1
  • tiff >= 3.8.2-5.36.1
Builds
ZYPP Patch Nr: 8721
SLE 11 SP1 DEBUGINFO
  • tiff-debuginfo >= 3.8.2-141.146.1
  • tiff-debugsource >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libtiff-devel >= 3.8.2-141.146.1
  • libtiff-devel-32bit >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libtiff-devel >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libtiff3 >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libtiff3 >= 3.8.2-141.146.1
  • libtiff3-32bit >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libtiff3 >= 3.8.2-141.146.1
  • tiff >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libtiff3 >= 3.8.2-141.146.1
  • libtiff3-x86 >= 3.8.2-141.146.1
  • tiff >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libtiff3 >= 3.8.2-141.146.1
  • libtiff3-32bit >= 3.8.2-141.146.1
  • tiff >= 3.8.2-141.146.1
Builds
SAT Patch Nr: 6475

© 2014 Novell