Novell Home

CVE-2012-1667

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-1667 at MITRE

Description

ISC BIND 9.x before 9.7.6-P1, 9.8.x before 9.8.3-P1, 9.9.x before 9.9.1-P1, and 9.4-ESV and 9.6-ESV before 9.6-ESV-R7-P1 does not properly handle resource records with a zero-length RDATA section, which allows remote DNS servers to cause a denial of service (daemon crash or data corruption) or obtain sensitive information from process memory via a crafted record.

NVD CVSS v2 Base Score: 8.5 (AV:N/AC:L/Au:N/C:P/I:N/A:C)

Novell/SUSE information

Novell Bugzilla entry: 765315, 792926

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CORE 9 for IBM S/390 31bit
SUSE CORE 9 for x86
  • bind >= 9.3.4-4.16
  • bind-devel >= 9.3.4-4.16
  • bind-utils >= 9.3.4-4.16
Builds
YOU Patch Nr: 12899
SUSE CORE 9 for IBM zSeries 64bit
  • bind >= 9.3.4-4.16
  • bind-devel >= 9.3.4-4.16
  • bind-utils >= 9.3.4-4.16
  • bind-utils-32bit >= 9-201207061342
Builds
YOU Patch Nr: 12899
SUSE CORE 9 for AMD64 and Intel EM64T
  • bind >= 9.3.4-4.16
  • bind-devel >= 9.3.4-4.16
  • bind-utils >= 9.3.4-4.16
  • bind-utils-32bit >= 9-201207061338
Builds
YOU Patch Nr: 12899
SUSE CORE 9 for AMD64 and Intel EM64T
  • bind >= 9.3.4-4.17
  • bind-devel >= 9.3.4-4.17
  • bind-utils >= 9.3.4-4.17
  • bind-utils-32bit >= 9-201206051621
Builds
YOU Patch Nr: 12888
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • bind-libs >= 9.6ESVR7P1-0.10.1
  • bind-utils >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • bind-libs >= 9.6ESVR7P1-0.10.1
  • bind-libs-32bit >= 9.6ESVR7P1-0.10.1
  • bind-utils >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SUSE Linux Enterprise 10 SP4 DEBUGINFO for AMD64 and Intel EM64T
SUSE Linux Enterprise 10 SP4 DEBUGINFO for IBM POWER
SUSE Linux Enterprise 10 SP4 DEBUGINFO for IBM zSeries 64bit
SUSE Linux Enterprise 10 SP4 DEBUGINFO for IPF
SUSE Linux Enterprise 10 SP4 DEBUGINFO for x86
  • bind-debuginfo >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • bind >= 9.6ESVR7P1-0.10.1
  • bind-chrootenv >= 9.6ESVR7P1-0.10.1
  • bind-devel >= 9.6ESVR7P1-0.10.1
  • bind-doc >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
  • bind >= 9.6ESVR7P1-0.10.1
  • bind-chrootenv >= 9.6ESVR7P1-0.10.1
  • bind-devel >= 9.6ESVR7P1-0.10.1
  • bind-devel-64bit >= 9.6ESVR7P1-0.10.1
  • bind-doc >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SUSE Linux Enterprise Server 10 SP4 for x86
  • bind >= 9.6ESVR7P1-0.10.1
  • bind-chrootenv >= 9.6ESVR7P1-0.10.1
  • bind-devel >= 9.6ESVR7P1-0.10.1
  • bind-doc >= 9.6ESVR7P1-0.10.1
  • bind-libs >= 9.6ESVR7P1-0.10.1
  • bind-utils >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SUSE Linux Enterprise Server 10 SP4 for IPF
  • bind >= 9.6ESVR7P1-0.10.1
  • bind-chrootenv >= 9.6ESVR7P1-0.10.1
  • bind-devel >= 9.6ESVR7P1-0.10.1
  • bind-doc >= 9.6ESVR7P1-0.10.1
  • bind-libs >= 9.6ESVR7P1-0.10.1
  • bind-libs-x86 >= 9.6ESVR7P1-0.10.1
  • bind-utils >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • bind >= 9.6ESVR7P1-0.10.1
  • bind-chrootenv >= 9.6ESVR7P1-0.10.1
  • bind-devel >= 9.6ESVR7P1-0.10.1
  • bind-devel-64bit >= 9.6ESVR7P1-0.10.1
  • bind-doc >= 9.6ESVR7P1-0.10.1
  • bind-libs >= 9.6ESVR7P1-0.10.1
  • bind-libs-64bit >= 9.6ESVR7P1-0.10.1
  • bind-utils >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • bind >= 9.6ESVR7P1-0.10.1
  • bind-chrootenv >= 9.6ESVR7P1-0.10.1
  • bind-devel >= 9.6ESVR7P1-0.10.1
  • bind-doc >= 9.6ESVR7P1-0.10.1
  • bind-libs >= 9.6ESVR7P1-0.10.1
  • bind-libs-32bit >= 9.6ESVR7P1-0.10.1
  • bind-utils >= 9.6ESVR7P1-0.10.1
Builds
ZYPP Patch Nr: 8169
SLE 11 SP1 DEBUGINFO
  • bind-debuginfo >= 9.6ESVR7P1-0.2.5.1
  • bind-debugsource >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Software Development Kit 11 SP1
  • bind-devel >= 9.6ESVR7P1-0.2.5.1
  • bind-devel-32bit >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Software Development Kit 11 SP1
  • bind-devel >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Desktop 11 SP1
  • bind-libs >= 9.6ESVR7P1-0.2.5.1
  • bind-utils >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Desktop 11 SP1
  • bind-libs >= 9.6ESVR7P1-0.2.5.1
  • bind-libs-32bit >= 9.6ESVR7P1-0.2.5.1
  • bind-utils >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • bind >= 9.6ESVR7P1-0.2.5.1
  • bind-chrootenv >= 9.6ESVR7P1-0.2.5.1
  • bind-doc >= 9.6ESVR7P1-0.2.5.1
  • bind-libs >= 9.6ESVR7P1-0.2.5.1
  • bind-utils >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Server 11 SP1
  • bind >= 9.6ESVR7P1-0.2.5.1
  • bind-chrootenv >= 9.6ESVR7P1-0.2.5.1
  • bind-doc >= 9.6ESVR7P1-0.2.5.1
  • bind-libs >= 9.6ESVR7P1-0.2.5.1
  • bind-libs-x86 >= 9.6ESVR7P1-0.2.5.1
  • bind-utils >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • bind >= 9.6ESVR7P1-0.2.5.1
  • bind-chrootenv >= 9.6ESVR7P1-0.2.5.1
  • bind-doc >= 9.6ESVR7P1-0.2.5.1
  • bind-libs >= 9.6ESVR7P1-0.2.5.1
  • bind-libs-32bit >= 9.6ESVR7P1-0.2.5.1
  • bind-utils >= 9.6ESVR7P1-0.2.5.1
Builds
SAT Patch Nr: 6388
SLE 11 SP2 DEBUGINFO
  • bind-debuginfo >= 9.6ESVR7P1-0.5.1
  • bind-debugsource >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Software Development Kit 11 SP2
  • bind-devel >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Software Development Kit 11 SP2
  • bind-devel >= 9.6ESVR7P1-0.5.1
  • bind-devel-32bit >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Desktop 11 SP2
  • bind-libs >= 9.6ESVR7P1-0.5.1
  • bind-utils >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Desktop 11 SP2
  • bind-libs >= 9.6ESVR7P1-0.5.1
  • bind-libs-32bit >= 9.6ESVR7P1-0.5.1
  • bind-utils >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • bind >= 9.6ESVR7P1-0.5.1
  • bind-chrootenv >= 9.6ESVR7P1-0.5.1
  • bind-doc >= 9.6ESVR7P1-0.5.1
  • bind-libs >= 9.6ESVR7P1-0.5.1
  • bind-utils >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Server 11 SP2
  • bind >= 9.6ESVR7P1-0.5.1
  • bind-chrootenv >= 9.6ESVR7P1-0.5.1
  • bind-doc >= 9.6ESVR7P1-0.5.1
  • bind-libs >= 9.6ESVR7P1-0.5.1
  • bind-libs-x86 >= 9.6ESVR7P1-0.5.1
  • bind-utils >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • bind >= 9.6ESVR7P1-0.5.1
  • bind-chrootenv >= 9.6ESVR7P1-0.5.1
  • bind-doc >= 9.6ESVR7P1-0.5.1
  • bind-libs >= 9.6ESVR7P1-0.5.1
  • bind-libs-32bit >= 9.6ESVR7P1-0.5.1
  • bind-utils >= 9.6ESVR7P1-0.5.1
Builds
SAT Patch Nr: 6382
SUSE Linux Enterprise Server 10 SP2 for x86
  • bind >= 9.3.4-1.31.31.1
  • bind-chrootenv >= 9.3.4-1.31.31.1
  • bind-devel >= 9.3.4-1.31.31.1
  • bind-doc >= 9.3.4-1.31.31.1
  • bind-libs >= 9.3.4-1.31.31.1
  • bind-utils >= 9.3.4-1.31.31.1
Builds
ZYPP Patch Nr: 8195
SUSE Linux Enterprise Server 10 SP2 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP2 for IBM zSeries 64bit
  • bind >= 9.3.4-1.31.31.1
  • bind-chrootenv >= 9.3.4-1.31.31.1
  • bind-devel >= 9.3.4-1.31.31.1
  • bind-doc >= 9.3.4-1.31.31.1
  • bind-libs >= 9.3.4-1.31.31.1
  • bind-libs-32bit >= 9.3.4-1.31.31.1
  • bind-utils >= 9.3.4-1.31.31.1
Builds
ZYPP Patch Nr: 8195
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • bind >= 9.3.4-1.36.1
  • bind-chrootenv >= 9.3.4-1.36.1
  • bind-devel >= 9.3.4-1.36.1
  • bind-doc >= 9.3.4-1.36.1
  • bind-libs >= 9.3.4-1.36.1
  • bind-utils >= 9.3.4-1.36.1
Builds
ZYPP Patch Nr: 8173
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • bind >= 9.3.4-1.36.1
  • bind-chrootenv >= 9.3.4-1.36.1
  • bind-devel >= 9.3.4-1.36.1
  • bind-doc >= 9.3.4-1.36.1
  • bind-libs >= 9.3.4-1.36.1
  • bind-libs-32bit >= 9.3.4-1.36.1
  • bind-utils >= 9.3.4-1.36.1
Builds
ZYPP Patch Nr: 8173

© 2014 Novell