Novell Home

CVE-2012-1108

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-1108 at MITRE

Description

The parse function in ogg/xiphcomment.cpp in TagLib 1.7 and earlier allows remote attackers to cause a denial of service (crash) via a crafted vendorLength field in an ogg file.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entries: 750689, 750690, 750691, 750693

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SLE 11 SP1 DEBUGINFO
  • taglib-debuginfo >= 1.5-19.23.4
  • taglib-debugsource >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SLE 11 SP1 DEBUGINFO
  • taglib-debuginfo >= 1.5-19.23.4
  • taglib-debuginfo-x86 >= 1.5-19.23.4
  • taglib-debugsource >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SLE 11 SP1 DEBUGINFO
  • taglib-debuginfo >= 1.5-19.23.4
  • taglib-debuginfo-32bit >= 1.5-19.23.4
  • taglib-debugsource >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • taglib-devel >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • taglib >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • taglib >= 1.5-19.23.4
  • taglib-x86 >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • taglib >= 1.5-19.23.4
  • taglib-32bit >= 1.5-19.23.4
Builds
SAT Patch Nr: 6179
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • taglib >= 1.4-20.8.2
  • taglib-devel >= 1.4-20.8.2
Builds
ZYPP Patch Nr: 8041
SUSE Linux Enterprise Server 10 SP4 for IPF
  • taglib >= 1.4-20.8.2
  • taglib-devel >= 1.4-20.8.2
  • taglib-x86 >= 1.4-20.8.2
Builds
ZYPP Patch Nr: 8041
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • taglib >= 1.4-20.8.2
  • taglib-64bit >= 1.4-20.8.2
  • taglib-devel >= 1.4-20.8.2
Builds
ZYPP Patch Nr: 8041
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • taglib >= 1.4-20.8.2
  • taglib-32bit >= 1.4-20.8.2
  • taglib-devel >= 1.4-20.8.2
Builds
ZYPP Patch Nr: 8041

© 2014 Novell