Novell Home

CVE-2011-3869

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-3869 at MITRE

Description

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to overwrite arbitrary files via a symlink attack on the .k5login file.

NVD CVSS v2 Base Score: 6.3 (AV:L/AC:M/Au:N/C:N/I:C/A:C)

Novell/SUSE information

Novell Bugzilla entries: 726372, 727024

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP1
  • puppet >= 2.6.12-0.6.1
sled11-sp1.x86-64
sles11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86
sles11-sp1.x86
sles11-sp1-vmware.x86-64
sles11-sp1.s390x
SAT Patch Nr: 5421
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • puppet >= 2.6.12-0.6.1
  • puppet-server >= 2.6.12-0.6.1
sled11-sp1.x86-64
sles11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86
sles11-sp1.x86
sles11-sp1-vmware.x86-64
sles11-sp1.s390x
SAT Patch Nr: 5421
openSUSE 11.3
  • puppet >= 0.25.4-4.7.1
  • puppet-server >= 0.25.4-4.7.1
openSUSE 11.4
  • puppet >= 2.6.4-4.11.1
  • puppet-server >= 2.6.4-4.11.1

© 2014 Novell