Novell Home

CVE-2011-3648

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-3648 at MITRE

Description

Cross-site scripting (XSS) vulnerability in Mozilla Firefox before 3.6.24 and 4.x through 7.0 and Thunderbird before 3.1.6 and 5.0 through 7.0 allows remote attackers to inject arbitrary web script or HTML via crafted text with Shift JIS encoding.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)

Novell/SUSE information

No Novell Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.3
  • MozillaFirefox-debuginfo >= 3.6.24-0.2.1
  • MozillaFirefox-debugsource >= 3.6.24-0.2.1
  • MozillaThunderbird-debuginfo >= 3.1.16-0.23.1
  • MozillaThunderbird-debugsource >= 3.1.16-0.23.1
  • MozillaThunderbird-devel-debuginfo >= 3.1.16-0.23.1
  • enigmail-debuginfo >= 1.1.2+3.1.16-0.23.1
  • mozilla-js192-debuginfo >= 1.9.2.24-0.2.1
  • mozilla-js192-debuginfo-32bit >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-debuginfo >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-debuginfo-32bit >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-debugsource >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-devel-debuginfo >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-gnome-debuginfo >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-gnome-debuginfo-32bit >= 1.9.2.24-0.2.1
openSUSE 11.3
  • MozillaFirefox >= 3.6.24-0.2.1
  • MozillaFirefox-branding-openSUSE >= 3.5-17.3.1
  • MozillaFirefox-branding-upstream >= 3.6.24-0.2.1
  • MozillaFirefox-translations-common >= 3.6.24-0.2.1
  • MozillaFirefox-translations-other >= 3.6.24-0.2.1
  • MozillaThunderbird >= 3.1.16-0.23.1
  • MozillaThunderbird-devel >= 3.1.16-0.23.1
  • MozillaThunderbird-translations-common >= 3.1.16-0.23.1
  • MozillaThunderbird-translations-other >= 3.1.16-0.23.1
  • enigmail >= 1.1.2+3.1.16-0.23.1
  • mozilla-js192 >= 1.9.2.24-0.2.1
  • mozilla-js192-32bit >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192 >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-32bit >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-buildsymbols >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-devel >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-gnome >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-translations-common >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-translations-common-32bit >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-translations-other >= 1.9.2.24-0.2.1
  • mozilla-xulrunner192-translations-other-32bit >= 1.9.2.24-0.2.1
openSUSE 11.4
  • MozillaFirefox >= 8.0-0.2.2
  • MozillaFirefox-branding-openSUSE >= 5.0-2.5.1
  • MozillaFirefox-branding-upstream >= 8.0-0.2.2
  • MozillaFirefox-buildsymbols >= 8.0-0.2.2
  • MozillaFirefox-devel >= 8.0-0.2.2
  • MozillaFirefox-translations-common >= 8.0-0.2.2
  • MozillaFirefox-translations-other >= 8.0-0.2.2
  • MozillaThunderbird >= 3.1.16-0.19.2
  • MozillaThunderbird-buildsymbols >= 3.1.16-0.19.2
  • MozillaThunderbird-devel >= 3.1.16-0.19.2
  • MozillaThunderbird-translations-common >= 3.1.16-0.19.2
  • MozillaThunderbird-translations-other >= 3.1.16-0.19.2
  • enigmail >= 1.1.2+3.1.16-0.19.2
  • mozilla-js192 >= 1.9.2.24-0.2.2
  • mozilla-js192-32bit >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192 >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-32bit >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-buildsymbols >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-devel >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-gnome >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-translations-common >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-translations-common-32bit >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-translations-other >= 1.9.2.24-0.2.2
  • mozilla-xulrunner192-translations-other-32bit >= 1.9.2.24-0.2.2
openSUSE 11.3
  • seamonkey-debuginfo >= 2.5-0.2.1
  • seamonkey-debugsource >= 2.5-0.2.1
openSUSE 11.3
openSUSE 11.4
  • seamonkey >= 2.5-0.2.1
  • seamonkey-dom-inspector >= 2.5-0.2.1
  • seamonkey-irc >= 2.5-0.2.1
  • seamonkey-translations-common >= 2.5-0.2.1
  • seamonkey-translations-other >= 2.5-0.2.1
  • seamonkey-venkman >= 2.5-0.2.1
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • MozillaFirefox >= 3.6.24-0.5.1
  • MozillaFirefox-translations >= 3.6.24-0.5.1
  • mozilla-xulrunner192 >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-gnome >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-translations >= 1.9.2.24-0.5.1
Builds
ZYPP Patch Nr: 7844
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • MozillaFirefox >= 3.6.24-0.5.1
  • MozillaFirefox-translations >= 3.6.24-0.5.1
  • mozilla-xulrunner192 >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-32bit >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-gnome >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-translations >= 1.9.2.24-0.5.1
  • mozilla-xulrunner192-translations-32bit >= 1.9.2.24-0.5.1
Builds
ZYPP Patch Nr: 7844
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • MozillaFirefox-branding-upstream >= 3.6.24-0.5.1
Builds
ZYPP Patch Nr: 7844
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • mozilla-nss >= 3.13.1-0.5.1
  • mozilla-nss-devel >= 3.13.1-0.5.1
  • mozilla-nss-tools >= 3.13.1-0.5.1
Builds
ZYPP Patch Nr: 7842
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • mozilla-nss >= 3.13.1-0.5.1
  • mozilla-nss-32bit >= 3.13.1-0.5.1
  • mozilla-nss-devel >= 3.13.1-0.5.1
  • mozilla-nss-tools >= 3.13.1-0.5.1
Builds
ZYPP Patch Nr: 7842
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • mozilla-nss-tools >= 3.13.1-0.5.1
Builds
ZYPP Patch Nr: 7842
SUSE Linux Enterprise Server 10 SP4 for IPF
  • mozilla-nss >= 3.13.1-0.5.1
  • mozilla-nss-devel >= 3.13.1-0.5.1
  • mozilla-nss-tools >= 3.13.1-0.5.1
  • mozilla-nss-x86 >= 3.13.1-0.5.1
Builds
ZYPP Patch Nr: 7842
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • mozilla-nss >= 3.13.1-0.5.1
  • mozilla-nss-64bit >= 3.13.1-0.5.1
  • mozilla-nss-devel >= 3.13.1-0.5.1
  • mozilla-nss-tools >= 3.13.1-0.5.1
Builds
ZYPP Patch Nr: 7842

© 2014 Novell