Novell Home

CVE-2011-3378

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-3378 at MITRE

Description

RPM 4.4.x through 4.9.x, probably before 4.9.1.2, allows remote attackers to cause a denial of service (memory corruption) and possibly execute arbitrary code via an rpm package with crafted headers and offsets that are not properly handled when a package is queried or installed, related to (1) the regionSwab function, (2) the headerLoad function, and (3) multiple functions in rpmio/rpmpgp.c.

NVD CVSS v2 Base Score: 9.3 (AV:N/AC:M/Au:N/C:C/I:C/A:C)

Novell/SUSE information

Novell Bugzilla entry: 720824

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CORE 9 for AMD64 and Intel EM64T
  • popt >= 1.7-177.29
  • popt-32bit >= 9-201111221459
  • popt-devel >= 1.7-177.29
  • popt-devel-32bit >= 9-201111221459
  • rpm >= 4.1.1-177.29
  • rpm-devel >= 4.1.1-177.29
  • rpm-python >= 4.1.1-177.29
Builds
YOU Patch Nr: 12839
SUSE Linux Enterprise SDK 10 SP3
  • rpm-devel >= 4.4.2-43.38.38.7
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
sles10-sp3.x86
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
ZYPP Patch Nr: 7793
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • popt >= 1.7-271.37.38.7
  • popt-32bit >= 1.7-271.37.38.7
  • popt-devel >= 1.7-271.37.38.7
  • popt-devel-32bit >= 1.7-271.37.38.7
  • rpm >= 4.4.2-43.38.38.7
  • rpm-devel >= 4.4.2-43.38.38.7
  • rpm-python >= 4.4.2-43.38.38.7
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
sles10-sp3.x86
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
ZYPP Patch Nr: 7793
SUSE Linux Enterprise Server 10 SP3
  • popt >= 1.7-271.37.38.7
  • popt-devel >= 1.7-271.37.38.7
  • rpm >= 4.4.2-43.38.38.7
  • rpm-devel >= 4.4.2-43.38.38.7
  • rpm-python >= 4.4.2-43.38.38.7
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
sles10-sp3.x86
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
ZYPP Patch Nr: 7793
SUSE Linux Enterprise Server 10 SP3
  • popt >= 1.7-271.37.38.7
  • popt-devel >= 1.7-271.37.38.7
  • popt-x86 >= 1.7-271.37.38.7
  • rpm >= 4.4.2-43.38.38.7
  • rpm-devel >= 4.4.2-43.38.38.7
  • rpm-python >= 4.4.2-43.38.38.7
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
sles10-sp3.x86
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
ZYPP Patch Nr: 7793
SUSE Linux Enterprise Server 10 SP3
  • popt >= 1.7-271.37.38.7
  • popt-64bit >= 1.7-271.37.38.7
  • popt-devel >= 1.7-271.37.38.7
  • popt-devel-64bit >= 1.7-271.37.38.7
  • rpm >= 4.4.2-43.38.38.7
  • rpm-devel >= 4.4.2-43.38.38.7
  • rpm-python >= 4.4.2-43.38.38.7
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
sles10-sp3.x86
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
ZYPP Patch Nr: 7793
SLE 11 SP1 DEBUGINFO
  • rpm-debuginfo >= 4.4.2.3-37.29.29.1
  • rpm-debugsource >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SLE 11 SP1 DEBUGINFO
  • rpm-debuginfo >= 4.4.2.3-37.29.29.1
  • rpm-debuginfo-x86 >= 4.4.2.3-37.29.29.1
  • rpm-debugsource >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SLE 11 SP1 DEBUGINFO
  • rpm-debuginfo >= 4.4.2.3-37.29.29.1
  • rpm-debuginfo-32bit >= 4.4.2.3-37.29.29.1
  • rpm-debugsource >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Software Development Kit 11 SP1
  • popt-devel >= 1.7-37.29.29.1
  • rpm-devel >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Software Development Kit 11 SP1
  • popt-devel >= 1.7-37.29.29.1
  • rpm-devel >= 4.4.2.3-37.29.29.1
  • rpm-x86 >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Software Development Kit 11 SP1
  • popt-devel >= 1.7-37.29.29.1
  • popt-devel-32bit >= 1.7-37.29.29.1
  • rpm-32bit >= 4.4.2.3-37.29.29.1
  • rpm-devel >= 4.4.2.3-37.29.29.1
  • rpm-devel-32bit >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Software Development Kit 11 SP1
  • popt-devel >= 1.7-37.29.29.1
  • rpm-32bit >= 4.4.2.3-37.29.29.1
  • rpm-devel >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • popt >= 1.7-37.29.29.1
  • rpm >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Server 11 SP1
  • popt >= 1.7-37.29.29.1
  • popt-x86 >= 1.7-37.29.29.1
  • rpm >= 4.4.2.3-37.29.29.1
  • rpm-x86 >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • popt >= 1.7-37.29.29.1
  • popt-32bit >= 1.7-37.29.29.1
  • rpm >= 4.4.2.3-37.29.29.1
  • rpm-32bit >= 4.4.2.3-37.29.29.1
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sles11-sp1.s390x
SAT Patch Nr: 5256
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • popt >= 1.7-271.42.2
  • popt-devel >= 1.7-271.42.2
  • rpm >= 4.4.2-43.42.2
  • rpm-devel >= 4.4.2-43.42.2
  • rpm-python >= 4.4.2-43.42.2
sles10-sp4.x86-64
sles10-sp4.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.x86
sles10-sp4.s390x
sles10-sp4.ia64
sles10-sp4.x86
sled10-sp4.x86
sle10-sp4-sdk.ia64
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sled10-sp4.x86-64
ZYPP Patch Nr: 7792
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • rpm-devel >= 4.4.2-43.42.2
sles10-sp4.x86-64
sles10-sp4.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.x86
sles10-sp4.s390x
sles10-sp4.ia64
sles10-sp4.x86
sled10-sp4.x86
sle10-sp4-sdk.ia64
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sled10-sp4.x86-64
ZYPP Patch Nr: 7792
SUSE Linux Enterprise Server 10 SP4 for IPF
  • popt >= 1.7-271.42.2
  • popt-devel >= 1.7-271.42.2
  • popt-x86 >= 1.7-271.42.2
  • rpm >= 4.4.2-43.42.2
  • rpm-devel >= 4.4.2-43.42.2
  • rpm-python >= 4.4.2-43.42.2
sles10-sp4.x86-64
sles10-sp4.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.x86
sles10-sp4.s390x
sles10-sp4.ia64
sles10-sp4.x86
sled10-sp4.x86
sle10-sp4-sdk.ia64
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sled10-sp4.x86-64
ZYPP Patch Nr: 7792
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • popt >= 1.7-271.42.2
  • popt-64bit >= 1.7-271.42.2
  • popt-devel >= 1.7-271.42.2
  • popt-devel-64bit >= 1.7-271.42.2
  • rpm >= 4.4.2-43.42.2
  • rpm-devel >= 4.4.2-43.42.2
  • rpm-python >= 4.4.2-43.42.2
sles10-sp4.x86-64
sles10-sp4.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.x86
sles10-sp4.s390x
sles10-sp4.ia64
sles10-sp4.x86
sled10-sp4.x86
sle10-sp4-sdk.ia64
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sled10-sp4.x86-64
ZYPP Patch Nr: 7792
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • popt >= 1.7-271.42.2
  • popt-32bit >= 1.7-271.42.2
  • popt-devel >= 1.7-271.42.2
  • popt-devel-32bit >= 1.7-271.42.2
  • rpm >= 4.4.2-43.42.2
  • rpm-devel >= 4.4.2-43.42.2
  • rpm-python >= 4.4.2-43.42.2
sles10-sp4.x86-64
sles10-sp4.ppc
sle10-sp4-sdk.x86-64
sle10-sp4-sdk.x86
sles10-sp4.s390x
sles10-sp4.ia64
sles10-sp4.x86
sled10-sp4.x86
sle10-sp4-sdk.ia64
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sled10-sp4.x86-64
ZYPP Patch Nr: 7792
openSUSE 11.3
  • rpm-debuginfo >= 4.8.0-5.3.1
  • rpm-debuginfo-32bit >= 4.8.0-5.3.1
  • rpm-debugsource >= 4.8.0-5.3.1
openSUSE 11.3
  • rpm >= 4.8.0-5.3.1
  • rpm-32bit >= 4.8.0-5.3.1
  • rpm-devel >= 4.8.0-5.3.1
openSUSE 11.4 DEBUGINFO
  • rpm-debuginfo >= 4.8.0-28.29.1
  • rpm-debuginfo-32bit >= 4.8.0-28.29.1
  • rpm-debugsource >= 4.8.0-28.29.1
openSUSE 11.4
  • rpm >= 4.8.0-28.29.1
  • rpm-32bit >= 4.8.0-28.29.1
  • rpm-devel >= 4.8.0-28.29.1

© 2014 Novell