Novell Home

CVE-2011-3048

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-3048 at MITRE

Description

The png_set_text_2 function in pngset.c in libpng 1.0.x before 1.0.59, 1.2.x before 1.2.49, 1.4.x before 1.4.11, and 1.5.x before 1.5.10 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted text chunk in a PNG image file, which triggers a memory allocation failure that is not properly handled, leading to a heap-based buffer overflow.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entries: 754745, 854395

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CORE 9 for AMD64 and Intel EM64T
  • libpng >= 1.2.5-182.185
  • libpng-32bit >= 9-201203302123
  • libpng-devel >= 1.2.5-182.185
Builds
YOU Patch Nr: 12872
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • libpng >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • libpng >= 1.2.8-19.35.4
  • libpng-32bit >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
  • libpng-devel-32bit >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Server 10 SP4 for IPF
  • libpng >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
  • libpng-x86 >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • libpng >= 1.2.8-19.35.4
  • libpng-64bit >= 1.2.8-19.35.4
  • libpng-devel >= 1.2.8-19.35.4
  • libpng-devel-64bit >= 1.2.8-19.35.4
Builds
ZYPP Patch Nr: 8043
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
  • libpng-devel-32bit >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
  • libpng12-0 >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libpng-devel >= 1.2.31-5.29.1
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-32bit >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-32bit >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libpng12-0 >= 1.2.31-5.29.1
  • libpng12-0-x86 >= 1.2.31-5.29.1
Builds
SAT Patch Nr: 6077

© 2014 Novell