Novell Home

CVE-2011-1529

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-1529 at MITRE

Description

The lookup_lockout_policy function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the db2 (aka Berkeley DB) or LDAP back end is used, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via vectors that trigger certain process_as_req errors.

NVD CVSS v2 Base Score: 7.8 (AV:N/AC:L/Au:N/C:N/I:N/A:C)

Novell/SUSE information

Novell Bugzilla entries: 719393, 743742

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.3
  • krb5-appl-clients-debuginfo >= 1.0-4.3.1
  • krb5-appl-debugsource >= 1.0-4.3.1
  • krb5-appl-servers-debuginfo >= 1.0-4.3.1
  • krb5-client-debuginfo >= 1.8.1-5.11.1
  • krb5-debuginfo >= 1.8.1-5.11.1
  • krb5-debuginfo-32bit >= 1.8.1-5.11.1
  • krb5-debugsource >= 1.8.1-5.11.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.8.1-5.11.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.8.1-5.11.1
  • krb5-server-debuginfo >= 1.8.1-5.11.1
openSUSE 11.3
  • krb5 >= 1.8.1-5.11.1
  • krb5-32bit >= 1.8.1-5.11.1
  • krb5-appl-clients >= 1.0-4.3.1
  • krb5-appl-servers >= 1.0-4.3.1
  • krb5-client >= 1.8.1-5.11.1
  • krb5-devel >= 1.8.1-5.11.1
  • krb5-devel-32bit >= 1.8.1-5.11.1
  • krb5-plugin-kdb-ldap >= 1.8.1-5.11.1
  • krb5-plugin-preauth-pkinit >= 1.8.1-5.11.1
  • krb5-server >= 1.8.1-5.11.1
openSUSE 11.4
  • krb5 >= 1.8.3-16.19.1
  • krb5-32bit >= 1.8.3-16.19.1
  • krb5-appl-clients >= 1.0-7.10.1
  • krb5-appl-servers >= 1.0-7.10.1
  • krb5-client >= 1.8.3-16.19.1
  • krb5-devel >= 1.8.3-16.19.1
  • krb5-devel-32bit >= 1.8.3-16.19.1
  • krb5-plugin-kdb-ldap >= 1.8.3-16.19.1
  • krb5-plugin-preauth-pkinit >= 1.8.3-16.19.1
  • krb5-server >= 1.8.3-16.19.1

© 2014 Novell