Novell Home

CVE-2011-0411

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-0411 at MITRE

Description

The STARTTLS implementation in Postfix 2.4.x before 2.4.16, 2.5.x before 2.5.12, 2.6.x before 2.6.9, and 2.7.x before 2.7.3 does not properly restrict I/O buffering, which allows man-in-the-middle attackers to insert commands into encrypted SMTP sessions by sending a cleartext command that is processed after TLS is in place, related to a "plaintext command injection" attack.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entries: 677792, 686590, 689178, 776967

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • postfix >= 2.5.6-4.10.1
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.ppc
sles10-sp3.x86-64
sles10-sp3.s390x
ZYPP Patch Nr: 7387
openSUSE 11.2
  • postfix-debuginfo >= 2.6.1-2.8.1
  • postfix-debugsource >= 2.6.1-2.8.1
  • postfix-mysql-debuginfo >= 2.6.1-2.8.1
  • postfix-postgresql-debuginfo >= 2.6.1-2.8.1
openSUSE 11.2
  • postfix >= 2.6.1-2.8.1
  • postfix-devel >= 2.6.1-2.8.1
  • postfix-doc >= 2.6.1-2.8.1
  • postfix-mysql >= 2.6.1-2.8.1
  • postfix-postgresql >= 2.6.1-2.8.1
openSUSE 11.3
  • postfix-debuginfo >= 2.7.1-2.4.1
  • postfix-debugsource >= 2.7.1-2.4.1
  • postfix-mysql-debuginfo >= 2.7.1-2.4.1
  • postfix-postgresql-debuginfo >= 2.7.1-2.4.1
openSUSE 11.3
  • postfix >= 2.7.1-2.4.1
  • postfix-devel >= 2.7.1-2.4.1
  • postfix-doc >= 2.7.1-2.4.1
  • postfix-mysql >= 2.7.1-2.4.1
  • postfix-postgresql >= 2.7.1-2.4.1
openSUSE 11.4 DEBUGINFO
  • postfix-debuginfo >= 2.7.2-13.14.1
  • postfix-debugsource >= 2.7.2-13.14.1
  • postfix-mysql-debuginfo >= 2.7.2-13.14.1
  • postfix-postgresql-debuginfo >= 2.7.2-13.14.1
openSUSE 11.4
  • postfix >= 2.7.2-13.14.1
  • postfix-devel >= 2.7.2-13.14.1
  • postfix-doc >= 2.7.2-13.14.1
  • postfix-mysql >= 2.7.2-13.14.1
  • postfix-postgresql >= 2.7.2-13.14.1
openSUSE 11.2
  • pure-ftpd-debuginfo >= 1.0.22-3.4.1
  • pure-ftpd-debugsource >= 1.0.22-3.4.1
openSUSE 11.2
  • pure-ftpd >= 1.0.22-3.4.1
openSUSE 11.3
  • pure-ftpd-debuginfo >= 1.0.29-2.3.1
  • pure-ftpd-debugsource >= 1.0.29-2.3.1
openSUSE 11.3
  • pure-ftpd >= 1.0.29-2.3.1
openSUSE 11.4 DEBUGINFO
  • pure-ftpd-debuginfo >= 1.0.29-8.9.1
  • pure-ftpd-debugsource >= 1.0.29-8.9.1
openSUSE 11.4
  • pure-ftpd >= 1.0.29-8.9.1
SUSE Linux Enterprise Server 10 SP2 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP2 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP2 for x86
  • postfix >= 2.2.9-10.30
sles10-sp2-ltss.s390x
sles10-sp2-ltss.x86-64
sles10-sp2-ltss.x86
ZYPP Patch Nr: 7527
Open Enterprise Server
  • postfix >= 2.1.1-1.26
core9.s390x
core9.s390
core9.ia64
sles9-nlpos.x86
core9.ppc
core9.x86-64
core9.x86
sles9-oes.x86
YOU Patch Nr: 12707
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • postfix >= 2.5.6-4.10.1
sled10-sp4.x86
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
sles10-sp4.x86-64
sles10-sp4.ia64
ZYPP Patch Nr: 7403
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • pure-ftpd >= 1.0.22-0.20.1
sles10-sp3.ppc
sles10-sp3.ia64
sles10-sp3.x86-64
sles10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7466
SLE 11 SP1 DEBUGINFO
  • postfix-debuginfo >= 2.5.6-5.6.1
  • postfix-debugsource >= 2.5.6-5.6.1
sles11-sp1.x86
sles11-sp1-vmware.x86
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86
sles11-sp1.x86-64
SAT Patch Nr: 4177
SUSE Linux Enterprise Software Development Kit 11 SP1
  • postfix-devel >= 2.5.6-5.6.1
sles11-sp1.x86
sles11-sp1-vmware.x86
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86
sles11-sp1.x86-64
SAT Patch Nr: 4177
SUSE Linux Enterprise Desktop 11 SP1
  • postfix >= 2.5.6-5.6.1
sles11-sp1.x86
sles11-sp1-vmware.x86
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86
sles11-sp1.x86-64
SAT Patch Nr: 4177
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • postfix >= 2.5.6-5.6.1
  • postfix-doc >= 2.5.6-5.6.1
  • postfix-mysql >= 2.5.6-5.6.1
sles11-sp1.x86
sles11-sp1-vmware.x86
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ppc
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86
sles11-sp1.x86-64
SAT Patch Nr: 4177
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • pure-ftpd >= 1.0.22-0.20.1
sles10-sp4.ia64
sles10-sp4.ppc
sles10-sp4.s390x
sled10-sp4.x86-64
sles10-sp4.x86-64
sled10-sp4.x86
sles10-sp4.x86
ZYPP Patch Nr: 7480
SUSE CORE 9 for AMD64 and Intel EM64T
  • postfix >= 2.1.1-1.28
Builds
YOU Patch Nr: 12786
SLE 11 SP1 DEBUGINFO
  • pure-ftpd-debuginfo >= 1.0.22-3.5.1
  • pure-ftpd-debugsource >= 1.0.22-3.5.1
sles11-sp1-vmware.x86
sles11-sp1.x86-64
sles11-sp1.s390x
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.ppc
sled11-sp1.x86
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4360
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • pure-ftpd >= 1.0.22-3.5.1
sles11-sp1-vmware.x86
sles11-sp1.x86-64
sles11-sp1.s390x
sles11-sp1.x86
sles11-sp1.ia64
sles11-sp1.ppc
sled11-sp1.x86
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4360

© 2014 Novell