Novell Home

CVE-2010-0736

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2010-0736 at MITRE

Description

Cross-site scripting (XSS) vulnerability in the view_queryform function in lib/viewvc.py in ViewVC before 1.0.10, and 1.1.x before 1.1.4, allows remote attackers to inject arbitrary web script or HTML via "user-provided input."

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)

Novell/SUSE information

Novell Bugzilla entry: 587357

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • viewvc >= 1.0.10-0.1
openSUSE 11.1
  • viewvc >= 1.0.10-0.1.2
openSUSE 11.2
  • viewvc >= 1.1.4-1.1.1

© 2014 Novell