Novell Home

CVE-2010-0304

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2010-0304 at MITRE

Description

Multiple buffer overflows in the LWRES dissector in Wireshark 0.9.15 through 1.0.10 and 1.2.0 through 1.2.5 allow remote attackers to cause a denial of service (crash) via a malformed packet, as demonstrated using a stack-based buffer overflow to the dissect_getaddrsbyname_request function.

NVD CVSS v2 Base Score: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entries: 565902, 590352

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CORE 9 for AMD64 and Intel EM64T
  • ethereal >= 0.10.13-2.51
Builds
YOU Patch Nr: 12725
Open Enterprise Server
  • ethereal >= 0.10.13-2.47
core9.s390x
sles9-nlpos.x86
core9.x86-64
sles9-oes.x86
core9.ia64
core9.ppc
core9.s390
core9.x86
YOU Patch Nr: 12593
openSUSE 11.0
  • wireshark-debuginfo >= 1.0.0-17.21
  • wireshark-debugsource >= 1.0.0-17.21
openSUSE 11.0
  • wireshark >= 1.0.0-17.21
  • wireshark-devel >= 1.0.0-17.21
openSUSE 11.1
  • wireshark-debuginfo >= 1.0.4-2.14.2
  • wireshark-debugsource >= 1.0.4-2.14.2
openSUSE 11.1
  • wireshark >= 1.0.4-2.14.2
  • wireshark-devel >= 1.0.4-2.14.2
openSUSE 11.2
  • wireshark-debuginfo >= 1.2.1-3.11.2
  • wireshark-debugsource >= 1.2.1-3.11.2
openSUSE 11.2
  • wireshark >= 1.2.1-3.11.2
  • wireshark-devel >= 1.2.1-3.11.2
SUSE Linux Enterprise SDK 11 GA
  • wireshark >= 1.0.5-1.34.1
  • wireshark-devel >= 1.0.5-1.34.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-sdk.x86
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.x86-64
sles11.x86-64
sle11-sdk.ppc
sle11-debuginfo.x86
sles11.s390x
sles11.x86
sle11-sdk.ia64
sles11.ppc
sle11-debuginfo.s390x
sled11.x86
sles11.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 2082
SUSE Linux Enterprise SDK 11 GA
  • wireshark-devel >= 1.0.5-1.34.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-sdk.x86
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.x86-64
sles11.x86-64
sle11-sdk.ppc
sle11-debuginfo.x86
sles11.s390x
sles11.x86
sle11-sdk.ia64
sles11.ppc
sle11-debuginfo.s390x
sled11.x86
sles11.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 2082
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • wireshark >= 1.0.5-1.34.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-sdk.x86
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.x86-64
sles11.x86-64
sle11-sdk.ppc
sle11-debuginfo.x86
sles11.s390x
sles11.x86
sle11-sdk.ia64
sles11.ppc
sle11-debuginfo.s390x
sled11.x86
sles11.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 2082
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • ethereal >= 0.10.14-16.41.1
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.x86
sles10-sp3.ppc
sles10-sp3.ia64
sled10-sp3.x86
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 6890
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • ethereal >= 0.10.14-16.41.1
  • ethereal-devel >= 0.10.14-16.41.1
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.x86
sles10-sp3.ppc
sles10-sp3.ia64
sled10-sp3.x86
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 6890
SUSE Linux Enterprise SDK 10 SP3
  • ethereal-devel >= 0.10.14-16.41.1
sles10-sp3.s390x
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sles10-sp3.x86
sles10-sp3.ppc
sles10-sp3.ia64
sled10-sp3.x86
sles10-sp3.x86-64
sle10-sp3-sdk.s390x
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 6890
SUSE Linux Enterprise Server for SAP 10 SP2
  • ethereal >= 0.10.14-16.40.3
  • ethereal-devel >= 0.10.14-16.40.3
sle10-sp2-sdk.x86-64
sles10-sp2.ppc
sled10-sp2.x86-64
sle10-sp2-sdk.s390x
sles10-sp2.s390x
sle10-sp2-sdk.ia64
sle10-sp2-sdk.ppc
sled10-sp2.x86
sle10-sp2-sdk.x86
sles10-sp2.x86-64
sles10-sp2.x86
sles10-sp2.ia64
ZYPP Patch Nr: 6889
SUSE Linux Enterprise SDK 10 SP2
  • ethereal-devel >= 0.10.14-16.40.3
sle10-sp2-sdk.x86-64
sles10-sp2.ppc
sled10-sp2.x86-64
sle10-sp2-sdk.s390x
sles10-sp2.s390x
sle10-sp2-sdk.ia64
sle10-sp2-sdk.ppc
sled10-sp2.x86
sle10-sp2-sdk.x86
sles10-sp2.x86-64
sles10-sp2.x86
sles10-sp2.ia64
ZYPP Patch Nr: 6889

© 2014 Novell