Novell Home

CVE-2009-0789

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2009-0789 at MITRE

Description

OpenSSL before 0.9.8k on WIN64 and certain other platforms does not properly handle a malformed ASN.1 structure, which allows remote attackers to cause a denial of service (invalid memory access and application crash) by placing this structure in the public key of a certificate, as demonstrated by an RSA public key.

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entries: 459468, 489641, 629905

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.1
  • openssl-debuginfo >= 0.9.8h-28.8.1
  • openssl-debugsource >= 0.9.8h-28.8.1
openSUSE 11.1
  • libopenssl-devel >= 0.9.8h-28.8.1
  • libopenssl0_9_8 >= 0.9.8h-28.8.1
  • libopenssl0_9_8-32bit >= 0.9.8h-28.8.1
  • libopenssl0_9_8-64bit >= 0.9.8h-28.8.1
  • openssl >= 0.9.8h-28.8.1
  • openssl-doc >= 0.9.8h-28.8.1
openSUSE 11.0
  • openssl-debuginfo >= 0.9.8g-47.4
  • openssl-debugsource >= 0.9.8g-47.4
openSUSE 11.0
  • libopenssl-devel >= 0.9.8g-47.4
  • libopenssl0_9_8 >= 0.9.8g-47.4
  • libopenssl0_9_8-32bit >= 0.9.8g-47.4
  • libopenssl0_9_8-64bit >= 0.9.8g-47.4
  • openssl >= 0.9.8g-47.4
  • openssl-certs >= 0.9.8g-47.4
  • openssl-doc >= 0.9.8g-47.4
SUSE Linux Enterprise SDK 11 GA
  • libopenssl-devel >= 0.9.8h-30.12.1
sles11.s390x
sles11.x86-64
sle11-debuginfo.ppc
sles11.ppc
sles11.x86
sle11-debuginfo.s390x
sle11-sdk.ia64
sles11.ia64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
sle11-debuginfo.ia64
SAT Patch Nr: 772
SUSE Linux Enterprise Desktop 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.12.1
  • openssl >= 0.9.8h-30.12.1
sles11.s390x
sles11.x86-64
sle11-debuginfo.ppc
sles11.ppc
sles11.x86
sle11-debuginfo.s390x
sle11-sdk.ia64
sles11.ia64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
sle11-debuginfo.ia64
SAT Patch Nr: 772
SUSE Linux Enterprise Desktop 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.12.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.12.1
  • openssl >= 0.9.8h-30.12.1
sles11.s390x
sles11.x86-64
sle11-debuginfo.ppc
sles11.ppc
sles11.x86
sle11-debuginfo.s390x
sle11-sdk.ia64
sles11.ia64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
sle11-debuginfo.ia64
SAT Patch Nr: 772
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.12.1
  • openssl >= 0.9.8h-30.12.1
  • openssl-doc >= 0.9.8h-30.12.1
sles11.s390x
sles11.x86-64
sle11-debuginfo.ppc
sles11.ppc
sles11.x86
sle11-debuginfo.s390x
sle11-sdk.ia64
sles11.ia64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
sle11-debuginfo.ia64
SAT Patch Nr: 772
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.12.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.12.1
  • openssl >= 0.9.8h-30.12.1
  • openssl-doc >= 0.9.8h-30.12.1
sles11.s390x
sles11.x86-64
sle11-debuginfo.ppc
sles11.ppc
sles11.x86
sle11-debuginfo.s390x
sle11-sdk.ia64
sles11.ia64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
sle11-debuginfo.ia64
SAT Patch Nr: 772
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.12.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.12.1
  • openssl >= 0.9.8h-30.12.1
  • openssl-doc >= 0.9.8h-30.12.1
sles11.s390x
sles11.x86-64
sle11-debuginfo.ppc
sles11.ppc
sles11.x86
sle11-debuginfo.s390x
sle11-sdk.ia64
sles11.ia64
sled11.x86
sle11-sdk.s390x
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.x86-64
sle11-debuginfo.ia64
SAT Patch Nr: 772
SUSE Linux Enterprise SDK 10 SP2
  • openssl-doc >= 0.9.8a-18.30
sles10-sp2.ppc
sled10-sp2.x86
sle10-sp2-sdk.s390x
sles10-sp2.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2-debuginfo.s390x
sle10-sp2-sdk.x86
sles10-sp2.x86
sles10-sp2-debuginfo.ia64
sle10-sp2-sdk.ia64
sle10-sp2-sdk.ppc
sles10-sp2-debuginfo.ppc
sled10-sp2.x86-64
sles10-sp2-debuginfo.x86
sles10-sp2-debuginfo.x86-64
sles10-sp2.s390x
sles10-sp2.ia64
ZYPP Patch Nr: 6179
openSUSE 11.3
  • compat-openssl097g-debuginfo >= 0.9.7g-155.3.1
  • compat-openssl097g-debuginfo-32bit >= 0.9.7g-155.3.1
  • compat-openssl097g-debugsource >= 0.9.7g-155.3.1
openSUSE 11.3
  • compat-openssl097g >= 0.9.7g-155.3.1
  • compat-openssl097g-32bit >= 0.9.7g-155.3.1
openSUSE 11.4
  • compat-openssl097g >= 0.9.7g-158.159.1
  • compat-openssl097g-32bit >= 0.9.7g-158.159.1
SUSE CORE 9 for AMD64 and Intel EM64T
  • openssl >= 0.9.7d-15.48
  • openssl-devel >= 0.9.7d-15.48
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12759
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • compat-openssl097g >= 0.9.7g-13.21.1
sles10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
ZYPP Patch Nr: 7645
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • compat-openssl097g >= 0.9.7g-13.21.1
  • compat-openssl097g-32bit >= 0.9.7g-13.21.1
sles10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
ZYPP Patch Nr: 7645
SUSE Linux Enterprise Server 10 SP4 for IPF
  • compat-openssl097g >= 0.9.7g-13.21.1
  • compat-openssl097g-x86 >= 0.9.7g-13.21.1
sles10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
ZYPP Patch Nr: 7645
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • compat-openssl097g >= 0.9.7g-13.21.1
  • compat-openssl097g-64bit >= 0.9.7g-13.21.1
sles10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
ZYPP Patch Nr: 7645
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • compat-openssl097g >= 0.9.7g-13.21.1
  • compat-openssl097g-32bit >= 0.9.7g-13.21.1
sles10-sp3.x86
sles10-sp3.x86-64
sles10-sp3.ia64
sles10-sp3.ppc
sles10-sp3.s390x
ZYPP Patch Nr: 7644
SUSE Linux Enterprise Server 10 SP3
  • compat-openssl097g >= 0.9.7g-13.21.1
sles10-sp3.x86
sles10-sp3.x86-64
sles10-sp3.ia64
sles10-sp3.ppc
sles10-sp3.s390x
ZYPP Patch Nr: 7644
SUSE Linux Enterprise Server 10 SP3
  • compat-openssl097g >= 0.9.7g-13.21.1
  • compat-openssl097g-x86 >= 0.9.7g-13.21.1
sles10-sp3.x86
sles10-sp3.x86-64
sles10-sp3.ia64
sles10-sp3.ppc
sles10-sp3.s390x
ZYPP Patch Nr: 7644
SUSE Linux Enterprise Server 10 SP3
  • compat-openssl097g >= 0.9.7g-13.21.1
  • compat-openssl097g-64bit >= 0.9.7g-13.21.1
sles10-sp3.x86
sles10-sp3.x86-64
sles10-sp3.ia64
sles10-sp3.ppc
sles10-sp3.s390x
ZYPP Patch Nr: 7644
SUSE Linux Enterprise Desktop 11 SP1
  • compat-openssl097g >= 0.9.7g-146.20.1
Builds
SAT Patch Nr: 4913
SUSE Linux Enterprise Desktop 11 SP1
  • compat-openssl097g >= 0.9.7g-146.20.1
  • compat-openssl097g-32bit >= 0.9.7g-146.20.1
Builds
SAT Patch Nr: 4913
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • openssl >= 0.9.7d-15.39
  • openssl-devel >= 0.9.7d-15.39
  • openssl-doc >= 0.9.7d-15.39
core9.s390
core9.ia64
core9.s390x
core9.x86-64
sles9-nlpos.x86
core9.x86
core9.ppc
sles9-nld.x86
sles9-oes.x86
sles9-nld.x86-64
YOU Patch Nr: 12397
Novell Linux Desktop 9 for x86_64
  • openssl >= 0.9.7d-15.39
  • openssl-32bit >= 9-200904151544
  • openssl-devel >= 0.9.7d-15.39
  • openssl-devel-32bit >= 9-200904151544
  • openssl-doc >= 0.9.7d-15.39
core9.s390
core9.ia64
core9.s390x
core9.x86-64
sles9-nlpos.x86
core9.x86
core9.ppc
sles9-nld.x86
sles9-oes.x86
sles9-nld.x86-64
YOU Patch Nr: 12397
SUSE Linux Enterprise Desktop 11 GA
  • compat-openssl097g >= 0.9.7g-146.15.1
sle11-debuginfo.x86
sled11.x86
sle11-debuginfo.x86-64
sled11.x86-64
SAT Patch Nr: 789
SUSE Linux Enterprise Desktop 11 GA
  • compat-openssl097g >= 0.9.7g-146.15.1
  • compat-openssl097g-32bit >= 0.9.7g-146.15.1
sle11-debuginfo.x86
sled11.x86
sle11-debuginfo.x86-64
sled11.x86-64
SAT Patch Nr: 789
openSUSE 11.0
  • compat-openssl097g-debuginfo >= 0.9.7g-119.5
  • compat-openssl097g-debugsource >= 0.9.7g-119.5
openSUSE 11.0
  • compat-openssl097g >= 0.9.7g-119.5
  • compat-openssl097g-32bit >= 0.9.7g-119.5
  • compat-openssl097g-64bit >= 0.9.7g-119.5
openSUSE 11.1
  • compat-openssl097g-debuginfo >= 0.9.7g-146.10.1
  • compat-openssl097g-debuginfo-32bit >= 0.9.7g-146.10.1
  • compat-openssl097g-debuginfo-64bit >= 0.9.7g-146.10.1
  • compat-openssl097g-debugsource >= 0.9.7g-146.10.1
openSUSE 11.1
  • compat-openssl097g >= 0.9.7g-146.10.1
  • compat-openssl097g-32bit >= 0.9.7g-146.10.1
  • compat-openssl097g-64bit >= 0.9.7g-146.10.1

List of products where fixes are in QA

SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise SDK 11 GA
SUSE Linux Enterprise Server 11 GA

© 2014 Novell