Novell Home

CVE-2006-7227

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2006-7227 at MITRE

Description

Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to execute arbitrary code via a regular expression containing a large number of named subpatterns (name_count) or long subpattern names (max_name_size), which triggers a buffer overflow. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entry: 325921

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.1
  • apache2-mod_php5 >= 5.1.2-29.50
  • php5 >= 5.1.2-29.50
  • php5-bcmath >= 5.1.2-29.50
  • php5-bz2 >= 5.1.2-29.50
  • php5-calendar >= 5.1.2-29.50
  • php5-ctype >= 5.1.2-29.50
  • php5-curl >= 5.1.2-29.50
  • php5-dba >= 5.1.2-29.50
  • php5-dbase >= 5.1.2-29.50
  • php5-devel >= 5.1.2-29.50
  • php5-dom >= 5.1.2-29.50
  • php5-exif >= 5.1.2-29.50
  • php5-fastcgi >= 5.1.2-29.50
  • php5-filepro >= 5.1.2-29.50
  • php5-ftp >= 5.1.2-29.50
  • php5-gd >= 5.1.2-29.50
  • php5-gettext >= 5.1.2-29.50
  • php5-gmp >= 5.1.2-29.50
  • php5-iconv >= 5.1.2-29.50
  • php5-imap >= 5.1.2-29.50
  • php5-ldap >= 5.1.2-29.50
  • php5-mbstring >= 5.1.2-29.50
  • php5-mcrypt >= 5.1.2-29.50
  • php5-mhash >= 5.1.2-29.50
  • php5-mysql >= 5.1.2-29.50
  • php5-mysqli >= 5.1.2-29.50
  • php5-ncurses >= 5.1.2-29.50
  • php5-odbc >= 5.1.2-29.50
  • php5-openssl >= 5.1.2-29.50
  • php5-pcntl >= 5.1.2-29.50
  • php5-pdo >= 5.1.2-29.50
  • php5-pdo_mysql >= 5.1.2-29.50
  • php5-pdo_pgsql >= 5.1.2-29.50
  • php5-pdo_sqlite >= 5.1.2-29.50
  • php5-pear >= 5.1.2-29.50
  • php5-pgsql >= 5.1.2-29.50
  • php5-posix >= 5.1.2-29.50
  • php5-pspell >= 5.1.2-29.50
  • php5-shmop >= 5.1.2-29.50
  • php5-snmp >= 5.1.2-29.50
  • php5-soap >= 5.1.2-29.50
  • php5-sockets >= 5.1.2-29.50
  • php5-sqlite >= 5.1.2-29.50
  • php5-sysvmsg >= 5.1.2-29.50
  • php5-sysvsem >= 5.1.2-29.50
  • php5-sysvshm >= 5.1.2-29.50
  • php5-tidy >= 5.1.2-29.50
  • php5-tokenizer >= 5.1.2-29.50
  • php5-wddx >= 5.1.2-29.50
  • php5-xmlreader >= 5.1.2-29.50
  • php5-xmlrpc >= 5.1.2-29.50
  • php5-xmlwriter >= 5.1.2-29.50
  • php5-xsl >= 5.1.2-29.50
  • php5-zlib >= 5.1.2-29.50

© 2014 Novell