"The Resource Management Service could not open the data file" when loading the NDPS Broker
(Last modified: 02May2006)
This document (10100850) is provided subject to the disclaimer at the end of this document.
fact
Novell iPrint
Novell Distributed Print Services (NDPS)
symptom
"The Resource Management Service could not open the data file" when loading the NDPS Broker
"The Resource Management Service could not open the data file NDPSndps/resdir/ENGLISH/prndrv/[OS]/[HexNumber]/ARCHIVES/NDPSDRVR.ZIP. Error code 1. Make sure the file exists, is not protected and has not been corrupted, then try the task again."
cause
A Printer Agent has an associated driver that does not exist in the Broker's Resource Directory (sys:/ndps/RESDIR/).
fix
Ensure all drivers associated to Printer Agents exist in the Broker's resource directory. The steps below will walk you through how to accomplish this:
1. Note the path to the driver directory listed in the error statement.
2. Open the PADBTXT.CSV file using a spreadsheet application for the NDPS Manager that uses the Broker in question.
To find the PADBTXT.CSV file:
- Go to the NDPS Manager screen on the server console
- Hit ENTER on NDPS Manager Status and Control
- Hit ENTER on Database Options
- Hit ENTER on Examine Database
- Make note of the database location
- Browse to that directory and find the PADBTXT.CSV file
3. In the CSV file, find the driver that is reporting the error. Determine the Printer Agent(s) using that driver.
4. Use iManager or NWAdmin to change the driver association for that printer agent(s). Note: ensure the broker is loaded when you perform this step.
5. Re-load the Broker. The message will not appear.
document
Document Title: | "The Resource Management Service could not open the data file" when loading the NDPS Broker |
Document ID: | 10100850 |
Solution ID: | NOVL105584 |
Creation Date: | 03Apr2006 |
Modified Date: | 02May2006 |
Novell Product Class: | Novell Printing Services |
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