namcd will not load.

(Last modified: 22Dec2005)

This document (10100018) is provided subject to the disclaimer at the end of this document.

fact

Novell Open Enterprise Server (OES)

Linux User Management

namcd

symptom

namcd will not load.

Error: User profile file cannot be opened/does not exist

namcd will load non-secure.

change

Installed Groupwise onto the server

cause

Groupwise installs an older version of libldapsdk.so and libldapssl.so libraries. The namcd daemon cannot operate securely with these older libraries so it will fail to load. Groupwise however can operate with the older or newer models.

fix

namcd requires that LDAP be loaded and working in secure mode. Verify first that LDAP is loaded and working in secure mode. If after verifying that LDAP is working, and Groupwise has been installed on this server, you will need to delete the Groupwise libldapsdk.so and the libldapssl.so from the Groupwise locations. Typically these are in the following locations;

<path>/Groupwise/agents/lib

The easiest way to find all the libraries that are loaded when you have the problem is to use the ldd command. Find and delete all the GW libldapsdk and libldapssl libraries then reboot the server. Once the server is rebooted you should be able to successfully load namcd.

note

Oct 26 10:56:30 nbhsls1 /usr/sbin/namcd[25797]: Starting namcd..

Oct 26 10:56:30 nbhsls1 /usr/sbin/namcd[25797]: namcd populating the user hash tables

Oct 26 10:56:30 nbhsls1 /usr/sbin/namcd[25797]: User profile file cannot be opened/does not exist

document

Document Title: namcd will not load.
Document ID: 10100018
Solution ID: NOVL104628
Creation Date: 22Dec2005
Modified Date: 22Dec2005
Novell Product Class:Novell Directory Services

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