How to effectively test LDAP performance

(Last modified: 19Oct2004)

This document (10095050) is provided subject to the disclaimer at the end of this document.

fact

Novell eDirectory 8.7.3 for All Platforms

Novell eDirectory 8.7.1 for All Platforms

Novell eDirectory 8.7 for All Platforms

Novell eDirectory 8.6 for All Platforms

goal

How to effectively test LDAP performance

symptom

LDAP performance tests show low transaction per second

cause

Customers want to test the performance difference of eDirectory running on different platforms or operating systems as well as they want to compare eDirectory to other directory systems.  They find that the LDAP transactions per second are fairly low.

fix

There are serveral variables that make it impossible to give exact performance numbers that should be observed.  However, it most cases, with adequate hardware, Novell has experience between 600 - 1300 transactions per second and basic LDAP queries.  Here are some of the variables that will affect performance:

1. Number of users

2. What type of data is stored on the users

3. Secure connections or not

4. Convergence requirements

5. SSL or not

6. One bind with 1000s of queries or one bind/unbind per querie.

7. Concurrent users or not.

8. Directory writes or just reads

9. Are their a lot of deletions or not.

10. Other things the server will be used for.

 

It is critical that you understand what you are testing in regards to eDirectory and LDAP.  The LDAP test tool, the workstation limitation, the I/O channel and the LAN channel can adversely impact performance tests, giving false data.  It is imperative that ALL bottlenecks are removed when running tests.  The eDirectory server has not reached its maximum capacity if all processors are not around 97 oir 98% utilization.  If the processor time is at its maximum, the box can handle no more load.  Until then, something else is throttling the requests, not allowing full capacity on the server.  Common mistakes are:

1. Only running one thread of requests at the server.  This tests the capacity of the tool, not eDirectory.  Most test tools will allow you to use 100s of threads for the requests.  These settings should be explored until maximum is achieved.

2. The workstation can only handle so many requests.  At some point, the workstation processor or memory will be exceeded.  Several workstations may be required to test the full capacity of an eDirectory server.

3. The LAN channel is clogged.  If at all possible, the tests should be ran on the same segment as the server to eliminate any LAN issues.

The are other factors that may come into play that also should be handled to achieve maximum CPU usage during tests.

document

Document Title: How to effectively test LDAP performance
Document ID: 10095050
Solution ID: NOVL99379
Creation Date: 18Oct2004
Modified Date: 19Oct2004
Novell Product Class:novell directory services

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.