How do I reset the session time out in iManager?

(Last modified: 13May2004)

This document (10092850) is provided subject to the disclaimer at the end of this document.

goal

How do I reset the session time out in iManager?

fact

Novell iManager 2

symptom

After 30 minutes in iManager, the user is prompted to re-authenticate.

cause

There is a default session time out in Tomcat that is set to 30 minutes.

fix

The session time out can be changed by doing the following:

1. Change the session timeout by editing the webapps/nps/WEB-INF/web.xml file. Search for the following section:

<!--
   <session-config>
       <session-timeout>10</session-timeout>
   </session-config>
-->

2. Remove the comment lines from this section.  The section will now look like this:

   <session-config>
       <session-timeout>10</session-timeout>
   </session-config>

3. Stop and restart Tomcat
For information on how to stop and start Tomcat for the different platforms, see The Novell Documentation for iManager.  (There is a table listed under Installing and Using imanager Plug-ins | Downloading and Installing a Plug-in, Installing a Plug-in When RBS is Not Configured, step 9 Restart Tomcat.

This section is commented out by default. Uncomment the <session-config> section and change the <session-timeout> to whatever minutes you would like. Again, do not go above 1440 (which is 24 hours) because the session does need to timeout at some point so the portal can clean up connections.

note

The session section llisted above is commented out by default. Use caution when changing the <session-timeout>. Do not go above 1440 (which is 24 hours) because the session does need to timeout at some point so the portal can clean up connections. The reason for this is that if a person closes their browser without logging out, their session (including connections to eDirectory) are still valid until the session time out.  This could, potentially cause a security risk.

document

Document Title: How do I reset the session time out in iManager?
Document ID: 10092850
Solution ID: NOVL96900
Creation Date: 13May2004
Modified Date: 13May2004
Novell Product Class:management products

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