Error "System error 240 has occurred. The session was cancelled"
(Last modified: 14Jul2004)
This document (10092786) is provided subject to the disclaimer at the end of this document.
fact
Novell NetWare 5.1
Novell NetWare 6.0
Novell Native File Access Pack
Novell Native File Access Protocols
Novell Native File Access for Windows (CIFS)
symptom
Error "System error 240 has occurred. The session was cancelled"
Domain authentication fails when Primary Domain Controller and NetWare CIFS server are in different subnets.
cause
On the NetWare CIFS server, the Authentication Mode was set to 'domain'.
If any of the above three errors occur, the The NetWare CIFS server won't get a reply to its NETLOGON query for a Primary Domain Controller of the given Domain, which it unicasted to the reversed IP address. The NetWare CIFS server will time out in about two seconds, and then broadcast the NETLOGON query for a Primary Domain Controller of the configured Domain. If no PDC for the configured Domain exists in the broadcast domain, the NetWare CIFS server will not be able to resolve the PDC nor establish a connection for passthru domain authentication. As a consequence, the Client for Microsoft Networks will return the message "System error 240 has occurred. The session was cancelled" to the user, when he/she tries to connect to the NetWare CIFS server with the NET USE command.
fix
This defect is fixed with the field test CIFS.NLM version 1.50 of June 9, 2004 (size 359,172 bytes) or later. You can obtain this field test version with Novell Technical Services.
Work-around: Configure the host name and IP address of the Primary Domain Controller for the configured domain in Console One the following way:
document
Document Title: | Error "System error 240 has occurred. The session was cancelled" |
Document ID: | 10092786 |
Solution ID: | NOVL96861 |
Creation Date: | 10May2004 |
Modified Date: | 14Jul2004 |
Novell Product Class: | Connectivity Products |
disclaimer
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.