Changing user's password in iManager returns a -632 error

(Last modified: 04May2004)

This document (10092343) is provided subject to the disclaimer at the end of this document.

fact

iManager 2.0.x

Novell iManager 2.x

eDir 8.7.3

eDir 8.7.1

symptom

Changing user's password in iManager returns a -632 error

cause

NICISDI.KEY file did not exist on the server.

fix

Verify the W0.KAP.Security object is configured with a valid "NDSPKI:SD Key Server DN" attribute and verify that a SYS:SYSTEM\NICI\NICISDI.KEY file exists on the server specified in the W0 "NDSPKI:SD Key Server DN" attribute. Verify the version of NICI on all servers is 2.4 or greater.

If there is a NICISDI.KEY file on the W0 server. SDIDIAG can be used to synchronize the key to all servers.

If there is not a NICISDI.KEY file on the W0 server. It is important to verify that NICI is version 2.4 or greater on the server. To verify the version, use NWCONFIG and look in the products installed list for NICI.  If it is not, update it to the latest version by going to http://download.novell.com or switch the W0 server to a server that has NICI 2.4 or greater. Locate your NetWare server license disk and copy the NFK license file (e.g. 123456789.NFK) to the SYS:SYSTEM directory of the W0 server and rename it to NICIFK with no extention.  Verify that NICISDI.XLM is loading in the AUTOEXEC.NCF.  Restart the server and the NICISDI.KEY file should be generated. SDIDIAG can then be used to synchronize the key to all servers.

For more information on SDIDIAG, see TID #10088626 - Using SDIDiag to gather specific SDKey information from servers.

document

Document Title: Changing user's password in iManager returns a -632 error
Document ID: 10092343
Solution ID: NOVL96445
Creation Date: 06Apr2004
Modified Date: 04May2004
Novell Product Class:Management Products

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