Errors when renewing TCP/IP address via DHCP with the ZENworks Desktop Agent installed

(Last modified: 19Aug2005)

This document (10091089) is provided subject to the disclaimer at the end of this document.

fact

Novell ZENworks for Desktops 4.0 - ZfD 4.0

Novell ZENworks 6.5 SP1 Desktop Management - ZfD6.5SP1

Novell ZENworks for Desktops 4.0 SP1b - ZfD 4.0 SP1b

Novell ZENworks for Desktops 4.0.1 - ZfD 4.0.1

Novell ZENworks Management Agent

Windows TCP/IP address received through DHCP

symptom

Errors when renewing TCP/IP address via DHCP with the ZENworks Desktop Agent installed

Error: "Your computer has lost the lease to its IP address" in the System Event Viewer

Error: "The semaphore timeout period has expired. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server."

cause

Workstation Manager, and more specifically the file NOVDHCP.DLL seems to be causing the problem. If this file is renamed, then the problem stops.

fix

Fixed in IPCTL.DLL Dated 16 July 2004 or newer in zfd401_ir5.exe or newer found at Novell Product Updates. This file is specifically in the ZfDAgent.MSI file installed on the workstations.

Workaround - Rename the NOVDHCP.DLL file on the workstation to something like NOVDHCP.OLD.

document

Document Title: Errors when renewing TCP/IP address via DHCP with the ZENworks Desktop Agent installed
Document ID: 10091089
Solution ID: NOVL95492
Creation Date: 09Feb2004
Modified Date: 19Aug2005
Novell Product Class:Management Products

disclaimer

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