Slow NAL startup or refresh

(Last modified: 20Nov2003)

This document (10087759) is provided subject to the disclaimer at the end of this document.

fact

NALDESK or NALWIN32 startup or refresh

Novell Application Launcher (NAL)

Novell ZENworks for Desktops 4.0.1 - ZFD401

Microsoft Windows NT 4.0

Microsoft Windows 2000

Microsoft Windows XP Professional

symptom

Slow NAL startup or refresh

At one customer site running NT4, ZfD32 nal started in about 20 seconds.  ZfD401 nal starts up in 50 seconds (from nalwin32 start until the NAL window appeared)

change

After applying the zfd4sp1b or zfd401 zfdagent.msi, the startup or refresh time for NAL increases

fix

After applying ZFDAGENT.MSI dated Nov 17, 2003 or later (available at the File Finder), the following regkey can be used:

HKLM\Software\Netware\NAL\1.0 <dword> SkipNalcacheSecurityCheck

When set to 1, NAL will skip a security check and possibly a security change on the nalcache directory.  The security check avoids an issue where the nalcache can't get removed for applications originally associated to the workstation and therefore put down by the workstation helper, but now are associated to the user.

When this key is not present, NAL performs the security check and also will change the security on the cache to be open to everyone.

Remember, by default, being a member of the Users group on the local machine is all that is necessary to run NAL.  This security check might be necessary for those that have altered the local user's file system permissions to be more restrictive than the default Windows permissions.

cause

Note: after setting the above regkey to 1, the NT4 customer reports the zfd401 nal startup time to be 17 seconds, down from 50 seconds.

fix

Make sure the Launcher Configuration setting "Always Evaluate Referrals" is turned off.  You can check this by opening the properties of a user, go to the Launcher Config tab, and look at the Object's Effective Settings.  This setting should only be turned on if users are connecting across slow links to get to a replica that exists locally.

Here's some other troubleshooting steps we used:

>Delete the HKLM\Software\Novell\ZENworks\<dword>MiddleTierPort and <string>MiddleTierAddress keys (if present).

>If it will be a particular application causing the problem (or Type of app, like Force Run associated apps), you can isolate the following way:

...go to the properties of the test user, modify the Launcher Config settings:

check on Top of Configuration Tree (this stops this user from receiving LC from higher in the tree)

turn off Read Groups for Applications (this stops this user from receiving apps associated via its groups)

set Application Inheritance Level to 0 (this stops this user from receiving apps associated to its parent containers)

...go to the properties of the test workstation object, modify the Launcher Config settings:

turn off Enable Workstation Helper

...try the NAL startup again.  If the problem is going to be with an application, then the only apps that can be causing the problem at this point is the apps seen in the properties of the test user, Applications page.  Try removing all the force run checkboxes in this page and then rerun the test to see if Force Run apps are causing the problem.

>If you suspect corruption of nalcache or the registry, you can remove all the history of NAL being on a workstation by deleting the following:

***Caution: this should only be done on a test workstation as a troubleshooting step - this will cause redistributions of apps***

c:\nalcache

HKLM\Software\NetWare\NAL

HKCU\Software\NetWare\NAL

>to see if the problem is on the wire - take a packet trace of every packet to and from the test workstation as it boots up, and stop the trace when the NAL window comes up.  If you don't have a packet capture utility, use TID 10070788.  Open an incident with Novell Technical Support if trace reading is not possible onsite.  Look for gaps in the trace after NAL requests leave the workstation.  Also, look for connections to replicas across the WAN being made, and then look at what the request is to narrow down the culprit.  Also, compare the trace against another trace taken from a workstation that does work.

>if the problem is not on the wire, look for the problem to be on the workstation.  Open Task Manager, choose the Performance tab, and watch the memory and CPU utilization during a NAL startup or refresh.  If NAL modules are spinning their cycles, you might see the utilization peg at 100% for several seconds.

 

document

Document Title: Slow NAL startup or refresh
Document ID: 10087759
Solution ID: NOVL93118
Creation Date: 11Oct2003
Modified Date: 20Nov2003
Novell Product Class:Management Products

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