How to establish the SSL connection using Softerra LDAP Browser?

(Last modified: 07Apr2003)

This document (10076962) is provided subject to the disclaimer at the end of this document.

goal

How to establish the SSL connection using  Softerra LDAP Browser?

fact

LDAP with SSL on Softerra LDAP browser

symptom

 LDAP server profile created with the SSL configuration enabled and still can't connect to the server. 

[ERROR 81] Can't contact LDAP server

cause

This kind of behavior occurs due to the absence of necessary SSL certificates in the certificate database, or the absence of the certificate database itself. This certificate database is required for an LDAP client library to establish the SSL connection.

fix

Create and populate a certificate database containing the necessary certificates manually.

To do this, please follow the procedure below:

Download and install the Netscape web browser version 4.XX.
Run the Netscape browser. Open URL: https://IP Address:Port
For example: https://192.56.55.200:636  or https://ldap.mycompany.com:636

Usually the LDAP secure port number is 636. You'll see the Netscape Certificate Name Check window. Follow the instructions provided therein and accept the server certificate for this and future sessions.

Close the Netscape browser
Copy the key3.db and cert7.db files from the Netscape user profile directory to the LDAP Administrator or LDAP Browser root directory.

Restart LDAP Administrator or LDAP Browser. Open the server profile. Change Port number at the General tab. Press Apply. Check the Try to use SSL box at the LDAP Settings tab. Press Apply. Press OK.

document

Document Title: How to establish the SSL connection using  Softerra LDAP Browser?
Document ID: 10076962
Solution ID: NOVL84166
Creation Date: 21Nov2002
Modified Date: 07Apr2003
Novell Product Class:Connectivity Products
NetWare
Novell eDirectory

disclaimer

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