Unable to upgrade Pervasive .SQL 2000i Support Pack 4

(Last modified: 27Feb2004)

This document (10076057) is provided subject to the disclaimer at the end of this document.

fact

Novell Advanced Audit Service (NAAS)

Pervasive SQL 2000i

NAAS is a discontinued product.  The replacement product is Nsure Audit.  For information on downloading, installing, and configuring Nsure Audit, please see TID 10091433.

symptom

Unable to upgrade Pervasive .SQL 2000i Support Pack 4

Error: Service Pack 4 (SP4) cannot find an installation of "Pervasive.SQL 2000i NetWare Server" to upgrade.
Vendor-customized installations cannot always be detected. Contact your application vendor to find out how to apply SP4.

cause

NetWare 6 ships with Pervasive SQL 2000i with Support Pack 3 installed, but the Service Pack 4 installation checks for the presence of SP3 by examining the BTI.CFG file for certain entries, which are not included as the product ships with NetWare 6.

fix

Add the following lines to SYS:\SYSTEM\BTI.CFG:

[InstallInfo]
InstallDir=i:\pvsw
SystemDir= i:\system
VersionLevel=7.90
PatchLevel=3
BuildLevel=230

Adjust the drive letter to reflect the location of the server's SYS volume where you are installing the support pack.

Then, retry the Support Pack 4 installation.

This is also documented on the Pervasive Support site. (Linked here)

document

Document Title: Unable to upgrade Pervasive .SQL 2000i Support Pack 4
Document ID: 10076057
Solution ID: NOVL83414
Creation Date: 25Oct2002
Modified Date: 27Feb2004
Novell Product Class:Netware Client

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