Mail not being processed when using GWAVA for viruses scanning at the MTA

(Last modified: 25Nov2003)

This document (10069173) is provided subject to the disclaimer at the end of this document.

fact

Novell GroupWise Internet Agent

Novell GroupWise 5.5 Enhancement Pack (EP)

Novell GroupWise 6

Novell GroupWise 5.5

GWAVA

symptom

Mail not being processed when using GWAVA for viruses scanning at the MTA

Messages stuck in the MSLOCAL\GWVSCAN directory

Error: "Waiting for task ngw-vscan-controller to complete.", when unloading the MTA

cause

Cause 1: Corrupt message stuck in the MTA queue.

Cause 2: In GWAVA you can specify a RBL service.  GWAVA has to query the RBL service frequently, if it is having trouble querying the site mail can back up.

fix

Fix for Cause 1: Down and exit the MTA. Rename the Mslocal directory and restart the MTA.  When the MTA restarts these directories will be re-created.  The mail from the old renamed directories can be copied into the corresponding newly created directories.
Note: More information on GWAVA can be obtained at the following URL: http://www.beginfinite.com/index.html

Also clearing GWGWAVA/vwork directory fixed problem for customer.

Fix for Cause 2: In GWAVA remove the RBL,  unload the MTA, rename the GWVSCAN directory,reload the MTA, and feed the files back thru a hundred or so at a time.

note

For GroupWise 6.5 apply support pack 1 seemed to fix the issue

document

Document Title: Mail not being processed when using GWAVA for viruses scanning at the MTA
Document ID: 10069173
Solution ID: NOVL74019
Creation Date: 14Mar2002
Modified Date: 25Nov2003
Novell Product Class:Groupware

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