Winsock error 10061 when attempting to install an iPrint printer

(Last modified: 22Nov2005)

This document (10066950) is provided subject to the disclaimer at the end of this document.

fact

Novell NetWare 6.0

Novell iPrint

iPrint/NDPS

symptom

Winsock error 10061 when attempting to install an iPrint printer

Error 404 when attempting to install an iPrint printer

Error 404 when trying to access the Map Tool.

Printer agents are not showing up in the iPrint map tool.

Printer agents don't appear in the iPrint Map Designer drop down list.

Page cannot be displayed when using web browser to access secure port 443.

Winsock error 10061 when adding Printer drivers.

cause

There is a port conflict on port 443 between iPrint and the Web Based products.  This can be verified by using Novell Remote Manager.  Open NRM by pointing your browser to http://server_ip_address:8008, login with Admin rights, and select WINSOCK 2.0 under MANAGE APPLICATIONS.  Next select Winsock 2 Resources then HTTPSTK.NLM.  If port 443 is not listed as one of the resources, then iPrint will not function correctly because of a port conflict with one or more of the Web Based Products.

According to the RFC, the IPP protocol requires port 443.  This cannot be changed to another port.  Several other web based products that run on NetWare 6 also use port 443.  These can be modified to use a different port, but doing so may cause problems for users attempting to access the web based services.  If you change the port number for an application, users will need to enter the new port number in their browser to access the service.

fix

Run iPrint and other web-based services on separate file servers.

Add a secondary ip address to the server running both iPrint and web services.  Then reinstall IPP  and configure it to use the secondary IP address following the steps in Using iPrint with a secondary IP address .

Find out which product is using port 443, and configure it to use a different port.  Use the Winsock 2 Resources list in NetWare Remote Manager to discover which application is using port 443.  Again, open NRM  and select WINSOCK 2.0 under MANAGE APPLICATIONS.  Next select Winsock 2 Resources.  From here, you can either go through each listed Winsock Application and look for port 443, or you can go to the Winsock 2 Resources list, click on "Winsock2 Socket List," and search for 443.  The NLM shown in the "Used By" column will belong to the application that is using port 443.   

Often the application using port 443 will show as MOD_TLS.NLM.  The following steps describe how to configure this NLM to use a different port.

1.  Check for multiple instances of MOD_TLS.NLM in the Winsock Applications list.  (If iFolder is installed, there should be two instances of MOD_TLS.NLM in the list.)  

2.  Determine which instance of MOD_TLS.NLM  is using port 443.  Open each one, and look for port 443.  If the MOD_TLS using port 443 is also using port 2200, that will be the Apache Administration.  If there is no port 2200 listed, that will be iFolder.

3.  If the problem is with iFolder, skip to step 5.   If Apache Administration needs to be changed, open the file SYS:\Apache\Conf\ADMINSERV.CONF,  search for 443, and change it to an unused port number.  The edited line will look something like this:

<IfModule mod_tls.c>
   SecureListen 137.65.63.116:444 "SSL CertificateIP"  (or "SSL Certificate DNS")

4. Restart Apache services by typing the following at the server console:
NVXADMDN
NVXADMUP

Skip to step 7.

5. To change iFolder to use a different port, open the file SYS:\Apache\Conf\HTTPD.CONF search 443, and change it to an unused port number.  The edited line will look something like this:

<IfModule mod_tls.c>
   SecureListen 137.65.63.116:444 "SSL CertificateIP"  (or "SSL Certificate DNS")

6.  Restart iFolder by typing the following at the server console:

7.  Unload and reload HTTPSTK.NLM to get it to listen on port 443.  Depending on what is installed on your server, there will be several other files that must be unloaded before httpstk can be unloaded.  It may be easier to restart the file server.

document

Document Title: Winsock error 10061 when attempting to install an iPrint printer
Document ID: 10066950
Solution ID: NOVL66804
Creation Date: 18Dec2001
Modified Date: 22Nov2005
Novell Product Class:NetWare
Web Services

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