Error:"D11B" selecting Sent Items folder.

(Last modified: 20Jan2004)

This document (10065532) is provided subject to the disclaimer at the end of this document.

fact

Novell GroupWise 5.5

Novell GroupWise 5.5 Enhancement Pack

Novell GroupWise 6

Novell GroupWise 6.5

Compaq iPAQ

Palm Pilot

symptom

Error:"D11B" selecting Sent Items folder.

Error:"D11B - Too Many Items"

Error:"D00F" when performing remote download.

Users may see multiple duplicate folders

Trash folder missing.

Folders missing from cabinet.

GWCHECK reports there are duplicate folders

"79 Duplicate folder names at same level" shows in Overall Stats for this run

cause

There are 2 separate problems with 2 separate causes.  In the first case the GWCHECK process is creating multiple (in some instances thousands) of invalid folders that may or may not be visible from the GroupWise client and in the second case it seems that opening the GroupWise mailbox with Outlook or synchronizing handheld devices is causing a problem.

fix

Update:  One defect has been fixed in GroupWise EP SP5 and 6 SP2 to prevent the problem caused by GWCheck.  Fixes have been made on the client and agent side (Client file fixed was GWENV1.DLL, NT agent file was GWENV1A.DLL, NLM agent file was GWENN3.NLM).  The GWCHECK options will still need to be run if the duplicate folders have been created.

Update: The problem caused when using Outlook or syncing handhelds has been fixed in GroupWise 6 SP4 in the agents, GWCheck and the client.  The client file is GWMSP132.DLL, the GWCheck file is GWENV1.DLL, the NT Agent file is GWENV1A.DLL and the NLM Agent file is GWENN3.NLM all dated 20 March 2003 or later.  Search for these files on filefinder and install a patch that contains these files or newer versions.  This fix will not be available in earlier versions of GroupWise

For GroupWise 6 fix the problems in the following way:

  1. Run a normal contents check on the Post Office
  2. In ConsoleOne select the users that you want to run the check on
  3. Select Tools | GroupWise Utilities | Mailbox/Library Maintenance
  4. Select Contents and Fix problems.
  5. On the Databases tab deselect Message
  6. On the Misc tab enter DelDupFolders in the Support Options field
  7. Select Run.
  8. Keep running steps 1 to 7 until all the folders have been deleted.

Install the GWMSP132.DLL on all clients in the WINDOWS\SYSTEM32 directory.

For GroupWise 5.5 Enhancement Pack the fix is included is the SP 5 build.  Run with the following options:

  1.  Run a normal Contents check on the Post Office
  2. Create a file called GWCHECK.CFG in the directory where you run GWCheck from.
  3. Open this file in Notepad and enter DelDupFolders as the first line and hit <Enter> afterwards.
  4. Start GWCheck and run another Contents check on the whole Post Office.  GWCheck will detect the presence of the GWCHECK.CFG and run a special check to remove the duplicate folder records.

It may be necessary to run this entire process a number of times to remove all of the problem folder records.  It will also be necessary to run this special check option on a regular basis as the folders will continue to be created.  There is a fix in EPSP5 that will prevent the folders from being created.  Once SP5 has been applied there will be no need to run the special GWCheck again.

document

Document Title: Error:"D11B" selecting Sent Items folder.
Document ID: 10065532
Solution ID: NOVL61375
Creation Date: 22Oct2001
Modified Date: 20Jan2004
Novell Product Class:Groupware
NetWare

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