Error: SPOOL32 caused an invalid page fault in module DPPWIN32.DLL at 0137:01ae338f
(Last modified: 15Jan2003)
This document (10062219) is provided subject to the disclaimer at the end of this document.
fact
Novell Client32 v 3.30
NetWare 5.1
NetWare 5.0
Novell NetWare 4.11
NDS 8
symptom
Error: SPOOL32 caused an invalid page fault in module DPPWIN32.DLL at 0137:01ae338f
Prior versions of the client do not cause Spool32 to page fault in DPPWIN32.DLL.
NDPS printer agents are not able to be installed onto a workstation using the Add Printer Wizard.
The workstations usually GPFs after the drivers are downloaded, but prior to the printer actually being installed.
The NetWare 4.11 server holds a copy of DS of the container where the NDPS printer agents are being created.
The NetWare 5.1 server with NDS 8 does not hold a copy of DS of the container where the NDPS printer agents are being created.
change
The client was updated to v3.30.
cause
Novell Client32 v3.30 DPPWIN32.DLL dated 21JUL2000 is looking for the GUID attribute on the printer agent object. The printer agent does not contain a GUID attribute and this causes SPOOL32 to crash.
fix
The problem has been reported to engineering.
Place a DS replica of the container where the printer agents reside onto a server running NDS version 8. After applying the replica on that server, NDS version 8 will add the GUID attribute to the printer agent if one does not currently exist. This GUID attribute will be pushed out to all the other servers in the replica and the workstation will not GPF in SPOOL32 when the printer agents are being added to the workstation.
For example, there are two servers in your tree; S1 and S2. S1 is a NetWare 4.11 server and S2 is a NetWare 5.x server running NDS 8. S1 has the master DS copy of the OU=NOGUID.O=NOVELL replica, but S2 only has a subordinate reference to the OU=NOGUID.O=NOVELL replica. If an NDPS printer agent were created, it would be created without a GUID. If S2 received a R/W replica of the OU=NOGUID.O=NOVELL container, the GUID attribute would be added the the NDPS printer agent. If the replica stayed on the NetWare 5.x NDS 8 server, then all printer agents created would have a GUID attribute added to it. If the OU=NOGUID.O=NOVELL replica were removed from the NetWare 5.x server, the current printer agents would retain the GUID attribute and associated value. However, any new printer agents would be created without a GUID and the problem would return.
WORKAROUNDS:
1.) Backrev your client to something before the v3.30 client. The prior clients do not check for the GUID attribute and therefore, they should not GPF when adding printer agents.
2.) If you have a server with DS 8 installed, you can add a replica to that server of where the printer agent exists. DS 8 is compatible with LDAP and LDAP requires a GUID on each object. If an object does not have the GUID attribute, the DS 8 server will add the GUID attribute and populate it with a value.
TROUBLESHOOTING: A LAN trace was taken of the workstation installing the printer agent. The last thing in the trace was a request from the client to look up the GUID attribute on the NDPS printer agent. The server replied with a -603, which is "no such attribute". It was at that time that the workstation would GPF. Using DSView (for NetWare 4.x) or DSBrowse (for NetWare 5.x), you can see if the printer agent has a GUID attribute. If it doesn't, then that is causing the workstation to GPF.
document
Document Title: | Error: SPOOL32 caused an invalid page fault in module DPPWIN32.DLL at 0137:01ae338f |
Document ID: | 10062219 |
Solution ID: | NOVL47124 |
Creation Date: | 02May2001 |
Modified Date: | 15Jan2003 |
Novell Product Class: | NetWare |
disclaimer
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.