Error: "Connection reset by Peer"

(Last modified: 21Jan2002)

This document (10060888) is provided subject to the disclaimer at the end of this document.

fact

Novell BorderManager 3.5

bm35c11.exe applied

NetWare 5.1

NW51SP2.EXE applied

symptom

Error: "Connection reset by Peer"

FTP client connection reset by FTP Proxy server

FTP Client gets connection errors when doing an LS of a directory

FTP client cannot list files in a directory

FTP PORT command fails to FTP proxy server

cause

Establish an FTP session through the proxy on TCP port 21. Request data via an FTP LS or GET request, which automatically sends an FTP PORT request to Proxy server. Proxy server, processing the FTP PORT command from the browser, resets TCP connections to the client and origin FTP server.

fix

Apply Proxy.nlm from PXY014.EXE.

FTP data channel setup via the PASV request. Listing a directory that does not contain any files (an empty directory), the FTP server returns a "550 No files Found" message. Subsequent request after the 550 is returned will cause the connection to be reset on both sides because the Proxy servers data request block is still active.

To reproduce:

1. using an active (non PASV) FTP client e.g. from Windows, establish an FTP session to the FTP proxy
2. When putting in the USER information, type
        anonymous$ftp.novell.com<CR>
3. You will get prompted for the password on ftp.novell.com next - use your username followed by @ character eg. ncashell@
4. change the directory to one that contains no files (ie. where you get an FTP 550 file not found error) and issue an FTP LIST command via an LS or DIR instruction
5. change the directory to any other directory and reissue an FTP LIST command
6. watch the connections get reset and a message appearing on the browser.

document

Document Title: Error: "Connection reset by Peer"
Document ID: 10060888
Solution ID: NOVL41730
Creation Date: 05Mar2001
Modified Date: 21Jan2002
Novell Product Class:Novell BorderManager Services

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.