How to address NDPS Manager Database corruption

(Last modified: 08Jun2006)

This document (10060060) is provided subject to the disclaimer at the end of this document.

goal

How to address NDPS Manager Database corruption

fact

Novell Distributed Print Services (NDPS) 2.1.1

Novell Distributed Print Services (NDPS) 2.0

Novell NetWare 5.1

Novell NetWare 5.0

symptom

NDPSM cannot load due to manager corruption.

NDPSM complains of NDPS Manager Database corruption.

NDPSM hangs when attempting to resynchronize the database.

All Printer Agents on one manager give an error when trying to load the Manager.

cause

When the server abends or is not shut down in a clean fashion the possibility of NDPS Manager database corruption arises.  The NDPSM.NLM uses the TTS system to protect the NDPS Manager database from corruption, but this does not protect against all forms of database corruption

fix

Try the following in order (each may fix the problem):

1.  If running NDPSM.NLM dated 18DEC2003 or later, then multiple backup copies of the PSM database exist in the VOL:\NDPS\XXXXXXXX.PSM directory.   The backup copies consist of a pair of .DAT and .IDX files.  The PSMDBSAV is of 1AM that morning.  The others are from 10 days ago (PSMDBSV1), 20 days ago (PSMDBSV2), 30 days ago (PSMDBSV3), and 40 days ago (PSMDBSV4).   Rename both the backup pair .DAT and .IDX files to PSMDB.DAT and PSMDB.IDX to cause the backup to be the active database files.  NDPSM.NLM dated 25AUG2005 and later does not maintain a copy of psmdb.idx with the .dat file.  Read the cause statement of TID 10099109 for deeper explanation of why and how.  Load NDPSM and the database will be in the condition of the time the backup was made. 

2.  If running NDPSM.NLM dated 10MAR2004 or later, then multiple text backup copies of the PSM database exist in CSV format in the VOL:\NDPS\XXXXXXXX.PSM.  The timing of the tiered backup coincides with what is explained above in step 1.  Download PAGen.exe from Novell's File Finder and read TID 10089128.  PAGen.exe is a workstation tool that will read a CSV file to create a new database, but contain all of the original printer agents.

3. Attempt to resynchronize the NDPS Manager database, this option can be found in NDPSM.NLM under "NDPS Manager Status and Control", "Database Options", "Resynchronize Database Files".

4. Attempt to restore the NDPS Manager database from backup.  Note that by default, the NDPS Manager creates a backup in NDS of the NDPS Manager database at 1:00am daily.  Any restore attempt will be restoring the database in the state it was in during the latest automatic or manual backup of the database.  To restore the database from the NDS-based backup, "NDPS Manager Status and Control", "Database Options", "Restore Database" and "From NDS".

5. Try moving the NDPS Manager to another server by unloading NDPSM.NLM at the original server and then attempting to load NDPSM.NLM as the same NDPS Manager object at another server.  Note that this will still end up using a copy of the NDPS Manager database restored from NDS when the NDPS Manager is brought up on the new server, but may overcome some problem which was being encountered only on the original server.

If the NDPS Manager's database is corrupted to the extent that it will not even allow the NDPS Manager to load, you may need to load NDPSM.NLM with the '/NODATABASE' option so that NDPSM.NLM will go straight to the "Database Options" screen where you can elect to resynchronize or restore the database.

6.  Rebuild the NDPS Manager Database. 
Follow TID 10092230.

document

Document Title: How to address NDPS Manager Database corruption
Document ID: 10060060
Solution ID: NOVL38610
Creation Date: 29Jan2001
Modified Date: 08Jun2006
Novell Product Class:NetWare
Novell eDirectory

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.