Assertion Failed Errors with ZENworks Sybase Database.

(Last modified: 06Feb2006)

This document (10059501) is provided subject to the disclaimer at the end of this document.

goal

Assertion Failed Errors with ZENworks Sybase Database.

fact

Novell ZENworks for Desktops 3 SP1

Novell ZENworks for Desktops 3.2

Novell ZENworks Workstation Inventory

symptom

Error: "Assertion Failed 201110".

Error: "Assertion Failed 201425".

Error: "Sybase Adaptive Server Anywhere Fatal Error ***Error*** Assertion Failed 101412.  Page number on page does not match page requested."

Count is 0 when reading free list index page.

Assertion Failed errors on the server console.

Unable to start the database. Displays "Assertion failed message".

cause

Sybase assertion problems are rare but can occur when the database is not shut down properly such as the database being up during a server abend or the database server is switched off prior to properly shutting down the database.

fix

Restore the database using a recent backup. See Backing Up the Inventory Database (Sybase) for more information.

If you do not have a database backup copy or the database copy cannot be restored, follow these instructions:
1.Take a backup of the MGMTDBS.NCF file located in SYS:\SYSTEM directory.
2. Modify the MGMTDBS.NCF file.
        a. Insert the -f parameter after the DBSRV7 parameter.
        b. Delete the path to other databases such as NAL.DB. Do not delete the MGMTDB path.
        c. Save the changes.
3. Stop the database. At the database server on NetWare server, type q.  If the database is not unloaded, type unload DBSRV7.
4. Do a java -killall on the server console to kill all java services if you cannot bring down inventory service separately.
5. Rename the MGMTDB.LOG transaction log file in the ZENWORKS\DATABASE directory.  This is necessary in order for the -f parameter to work properly when the database is loaded in step 6.
6. Load the database. At the database server console, type MGMTDBS.NCF.  The database will start in recovery mode, displaying the messages "Recovery complete" and "Database server stopped".
7. Delete the existing MGMTDBS.NCF and rename the backup copy of the file to MGMTDBS.NCF.
8. Load the database. At the database serve console, type MGMTDBS.NCF.

If the above 8 steps do not resolve the issue, follow these instructions:
1.  Delete the database object from the NDS container in which you are operating on.  The name of the database object is 'ZfD3InventoryDatabase'.
2.  Copy the existing database to a known location and delete all files in vol:/zenworks/database directory, where vol: is the volume which you chose to keep the database.  Do not delete the directory.
3.  Delete the file sys:\system\mgmtdbs.ncf.
4.  Delete all files in vol:/zenworks/Scandir, DBDir, EntMergeDir and EntPushDir.  Do not delete the directories.
5.  Run the ZfD3 install again and choose Sybase only for database only installation onto the same volume which you selected before.  Make sure you enter the siteid and sitename correctly and is unique.
6.  After successful installation, check if sybase is up and running and the database is mounted successfully.
7.  Associate the database object 'ZfD3InventoryDatabase' to the database location policy (Service Location Package).
8.  Start the Zenworks inventory service. ZfDStart.
9.  Send an inventory scan and check if it could be stored in the database.  Try some 10-20 workstations in a sequence.  The workstations should be stored successfully.

See Sybase's document 1010805 for further information on Assertion errors.

document

Document Title: Assertion Failed Errors with ZENworks Sybase Database.
Document ID: 10059501
Solution ID: NOVL36728
Creation Date: 04Jan2001
Modified Date: 06Feb2006
Novell Product Class:Management Products
NetWare

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