Microsoft Office 97 issues

(Last modified: 11Apr2002)

This document (10026497) is provided subject to the disclaimer at the end of this document.

goal

Microsoft Office 97 issues

fact

Novell NetWare 5.0

Microsoft Windows 98

Microsoft Windows 95

Novell Client 3.2 for Windows 95/98

Novell Client 3.1 SP1 for Windows 95/98

Microsoft Office 97 is installed on the machine.

Novell ZENworks for Desktops 2

symptom

Can't install OR uninstall MSOffice97 after installing the NetWare client.

Error: "ACMSetup: This program has performed an illegal operation ACM Setup caused invalid... kernel32.dll..."

Cannot install the client

Cannot install client

ZENworks continues to load on the pc

When installing Microsoft Office97 products on Microsoft Windows 95/98, you may receive the following error message:

Error: "This program has performed an illegal operation and will be shut down. If the problem persists, contact the program vendor.

If you click Details, you receive an error message similar to the following: ACMSETUP caused an invalid page fault in module KERNEL32.DLL at 0177:bff7be97."

cause

This problem may occur when the following conditions are true:
A. Using Microsoft Windows 95/98
-and-
B. You have your CD-ROM drive configured to use Direct Memory Access (DMA) in the Windows 98 Device Manager.

In one scenario involving ZENworks 2.0, a customer created a Policy Package for Admins that included a strange variable "%*WINVER...%CN%".

fix

Customer should call Microsoft: see http://support.microsoft.com/support.  At their KnowledgeBase (KB), select Office 97 as the product and use ACMSetup as the keyword.

Microsoft's solution suggests these steps for a possible workaround of this error:

"Disable DMA for the CD-ROM
1.  Click Start, point to Settings, and then click Control Panel.
2.  Double-click the System icon, and then click the Device Manager tab.
3.  Select View Devices By Type and click the plus sign to the left of CDROM.
4.  Click the CD-ROM drive you want to change, and then click Properties.
5.  In the CD-ROM Drive Properties dialog box, click the Settings tab.
6.  In Settings, clear the DMA check box. Click OK.
7.  Close the System Properties window, restart the computer, and then try installing one of the products listed at the beginning of this article to ensure that the error does not appear.

If this does not solve your problem, you may need to use the following additional steps.

Disable DMA for the Disk drive(s):
1.  Click Start, point to Settings, and then click Control Panel.
2.  Double-click the System icon, and then click the Device Manager tab.
3.  Select View Devices By Type and click the plus sign to the left of Disk drives.
4.  Click the disk drive you want to change, and then click Properties.
5.  In the Disk Drive Properties dialog box, click the Settings tab.
6.  In Settings, clear the DMA check box. Click OK.
7.  Repeat steps 4 through 6 for each disk drive.

Delete Product Folder and Reinstall
1.  Delete the folder created during the installation of the product that you would like to install. For instance, if you were installing Microsoft Office 97, you would need to delete your C:\Program Files\Microsoft Office folder.
2.  Restart Windows 98. On the Windows Start menu, click Shutdown. Select Restart, and click OK.
3.  Install one of the products listed at the beginning of this article.

After the installation is complete, repeat the appropriate steps in the sections above to re-enable DMA."

Disabling this variable cleared all the errors.  MSOffice97 was able to be installed and uninstalled as usual.

document

Document Title: Microsoft Office 97 issues
Document ID: 10026497
Solution ID: 1.0.55004369.2533870
Creation Date: 09Feb2000
Modified Date: 11Apr2002
Novell Product Class:NetWare

disclaimer

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