SQL*Loader for WIN32 platforms hangs on exit with Novell Client for Windows NT installed.

(Last modified: 26Mar2002)

This document (10023451) is provided subject to the disclaimer at the end of this document.

fact

Novell Client 4.6 SP2 for Windows NT

Oracle SQL Server (any platform, any version)

symptom

SQL*Loader for WIN32 platforms hangs on exit with Novell Client for Windows NT installed.

SQL*Loader for WIN32 platforms (SQLLDR80.EXE, SQLLDR73.EXE, etc.) appears to hang after completing data upload, i.e. right when the utility should be exiting and returning to the command prompt.

Reverting to the Microsoft Client Service for NetWare Networks allows SQL*Loader to run successfully.

cause

Unknown at this time; neither Novell nor Oracle have been able to duplicate at will.

fix

Background:

The SQL*Loader utility is a utility which exists for each supported Oracle platform (Unix, WIN32, etc.) which parses text-based input files and uploads the data to a running Oracle SQL server. A common use of this utility is running automated uploading batches to transparently export data from one database system and import it into an Oracle-based SQL server.

Customers have reported that with the Novell Client for Windows NT installed, the WIN32 version of SQL*Loader sometimes hangs right when the utility has finished uploading data and should be exiting. For sites running automatic data imports and exports this causes the batch process to hang until the process is manually terminated.

This does not happen to all customers, and efforts to duplicate the issue in order to determine cause have not been successful. Customers who can duplicate the issue at will and can open an incident with Novell and possibly send a workstation or drive image to assist in duplication are encouraged to do so.

Workarounds:

Customers have reported that installing the Microsoft Client Service for NetWare does not show the same problem.

Another option may be to run the SQL*Loader process on a different workstation or platform.

Troubleshooting steps should include installing the Novell Client 4.7 for Windows NT & 2000 or later to determine whether the issue still exists. If the Novell Client for Windows NT is installed with IP-only or IP & IPX support, try installing the Novell client using IPX-only support and/or try making IPX the preferred protocol on the "Protocol Preferences" tab of the Novell client properties. Determine what else it unique about the workstation configuration. i.e. Are the same results still achieved with all workstations or with a workstation on which a clean installation of Windows NT is performed (i.e. no OEM pre-install image, no virus software, etc.)

document

Document Title: SQL*Loader for WIN32 platforms hangs on exit with Novell Client for Windows NT installed.
Document ID: 10023451
Solution ID: 1.0.43105450.2444764
Creation Date: 16Dec1999
Modified Date: 26Mar2002
Novell Product Class:NetWare

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