-497 DSRepair error NDS database not open

(Last modified: 03Sep2002)

This document (10021666) is provided subject to the disclaimer at the end of this document.

fact

Novell NetWare 4.11

Formerly TID 2914013

symptom

-497 DSRepair error NDS database not open

Error occurs while re-installing Directory Services on a server that DS was removed from.  

While trying to login or preparing to copy DS files, an error occurs.

An internal error has occurred: DSI cannot translate a unicode string to local. There may be a problem with the unicode translation files.  Error description: unknown error -497 (EEEEEEOF HEX) (DSI -4.10-21)

NDS database will not open and appears corrupt

Could not login to server or map a drive.

Server name is different in DSRepair.

cause

Either missing the SYS: LOGIN\NLS directory structure or the SYS:LOGIN\NLS directory structure exists but the directory is empty.  Containers no *.001 files.

Out of date disk controller drivers

fix

To troubleshoot:

Load RCONSOLE and gain remote access to the failed server.

Once connected, take the option to do a "directory scan"  from the "Available Options" menu which is displayed after pressing ALT F1.
Do a directory scan on SYS:LOGIN\NLS to check for the existence of the unicode files  (.001 extension files)

2 conditions are possible:
  1)   The SYS:LOGIN\NLS or SYS:LOGIN directory do not exist.
  2)   The directory and sub directory exist but are empty or the unicode files do not exist.

First make sure that there is no NLS directory, in some cases such as low free blocks,(less than 10-15%) the NLS directory has been corrupted and appeared as a file.  If this is the case rename the file and try the install once more after making sure the SYS vol has sufficient free blocks, 20% or more.

The problem is that there are corrupt unicode files.  In order to re-open the database you must reinstall the pre-install files.  This will allow the database to reopen.

There are two possible ways to recopy the necessary files:

One:
Locate the 4.10/4.11 cd and mount the cd volume, then
  1)   Load install |  Copy Files Option | pointing the file location to the cd ROM volume.
  2)   Specify option to copy pre-install files
          This option will check for the existence of SYS: SYSTEM,  PUBLIC, LOGIN  and Create files.  It then populates the LOGIN directory with the needed files,  creates the Login\NLS directory and populates with the unicode files, creates the Login\NLS\English directory and populates with the message and help files.
   3)    At this point, re-boot server and DS should open, provided it is not corrupt.  Patch the server and load LAN and Disk Drivers.

TWO: When DS has been removed from the server andl the unicode files need to be installed:
   1)   RCONSOLE into the server with the problem and select  Transfer Files to Server.  (See additional notes for methods of doing this.)
   2)   From another File Server (if available), copy the unicode files (*.001) from the login\NLS directory from the other server to the login\NLS directory of the failed server.
   3)   At this point the server should boot up,  it is still advisable to do a preliminary file copy and copy system and public files again.  
The issue here is, other files could be corrupt.

If the SYS:LOGIN\NLS subdirectory does not exist, do not try to RCONSOLE the files in, this will create a file called NLS in the SYS:LOGIN Directory, and will make install - copy files option fail.  

*If this is already the case, delete the file called NLS.  To do this use either ips script file or INSTALL.NLM or another nlm that allows the deletion of a file by name.

ADDITIONAL NOTES:
To copy files using RCONSOLE "Transfer files to server" on NetWare 4.11

   A.) On the workstations invoking RCONSOLE, map a drive to another server at the same NetWare revision.
   B.) This will be the server from which you will copy the
          example: map i:=source server/sys:
   C.) Load RCONSOLE on the target, or problem server.  Steps 1 - 3 are important. RCONSOLE can accept a
        Dos drive mapping for the source of "Transfer files to server".  However, it can only accept a NetWare
        mapping for the target of "Transfer files to server".
   D.) To copy all files in SYS:LOGIN\NLS and SYS:\LOGIN\NLS\ENGLISH, perform these steps:
       1.) Select transfer files to server.
       2.) For the source, enter I:\LOGIN\NLS
       3.) For the destination choose SYS:LOGIN\NLS
       4.) Before repeating the process with F:\LOGIN\NLS\ENGLISH and SYS:LOGIN\NLS\ENGLISH,
            verify that the English Directory Exists with a directory scan of SYS:LOGIN\NLS\ENGLISH.  If the
            english directory does not exist, use NETBASIC to create the directory as follows:
           i.) Toggle to the System console and enter LOAD NETBASIC
           ii.) Type SHELL at the command prompt.
           iii.) Type CD\LOGIN\NLS
           iv.) Type MD ENGLISH
           v.) Type Exit followed by unload NETBASIC
      5.) Copy  files for the english subdirectory using the same steps as http above.

Other tools that can be used to copy files between servers can be obtained from the Tools section
of the Minimum Patch List.  This can be accessed from http://support.novell.com/produpdate/patchlist.html#toolshttp://support.novell.com/miscspatlst.shtmtm#tools

The">

The
additional tools are:
ToolBox Utility

As new versions come out, these numbers will change.  To use these tools, download and extract the readme files.
.

note

Booting the server NetWare 4.11 gets to point of loading ds.nlm and receives the following message on the system console:
   <date>  <time>  DS-5.73-24
           Directory Services:  Could not open local database
with this message attempt to run dsrepair and receive the following error message:
     Error Report
DSREPAIR-4.10-015:  Could not establish full access to record manager, error -497

Program execution cannot continue normally.
Press escape..
NDS database will not open and appears corrupt.

document

Document Title: -497 DSRepair error NDS database not open
Document ID: 10021666
Solution ID: 1.0.39474748.2405879
Creation Date: 15Nov1999
Modified Date: 03Sep2002
Novell Product Class:NetWare
Novell eDirectory

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.