Draft Messages from "System Administrator" are appearing in users' mailboxes.
(Last modified: 24Jan2003)
This document (10016805) is provided subject to the disclaimer at the end of this document.
fact
Novell GroupWise 5.5
Draft mail messages can be identified by the pencil icon associated with them.
Formerly TID 2948346
Defect 55356
symptom
Draft Messages from "System Administrator" are appearing in users' mailboxes.
Draft items from "System Administrator" are appearing in users' mailboxes.
To see draft items highlight the Mailbox in the GroupWise client, right click and choose PROPERTIES|DISPLAY and check the "DRAFT" box under Item Source.
Messages appear after doing a MAPI send from another application (i.e., Microsoft Word).
Messages appear after running the Exchange or Outlook clients against the GroupWise backend.
Mailbox folder properties must be set to display draft items (right-click on the Mailbox folder | Properties | Display; check the "Draft" box under "Item Source").
Draft messages seem to be duplicates of messages that were previously addressed to personal groups.
Problem most frequently appears when the items addressed to personal groups had been sent using a GroupWise 5.2 client (but not always).
"TO:" field matches the original sent item.
"Subject:" field matches the original sent item.
No text in the message body.
Mail view for the draft item is a New Mail Item view (has the Send, Cancel, Address, and Attach buttons).
Reply option is missing when highlighting the message and right clicking on it.
Forward option is missing when highlighting the message and right clicking on it.
Properties option is missing when highlighting the message and right clicking on it.
cause
These draft mail messages are appearing because the MAPI spooler (MAPISP32.EXE) is sending a "get outgoing queue" request to the GroupWise Message Store Provider (GWMSP132.DLL). The GroupWise Message Store Provider looks for any item referenced in the user database with a box type of "2" (outgoing) and a user status with the "submitted" bit set (in the user status field, a binary value of the 4th digit from the right (reading right to left) would be one of the following digits: 2, 6, 7, A, B, E, or F). By design, this submitted bit should only be set when a message is sent via MAPI and the client is unable to identify one or more recipients of the message. This queues the item for the MAPI Spooler so that it can try to deliver the item to that recipient (i.e., by looking for other profiles and attempting to deliver the item to that user). In most cases (if not all), the MAPI Spooler will also be unable to deliver the item to that recipient and will generate a message from "System Administrator" as is seen in the reported problem. However, it appears that this submitted bit might be getting set by normal (non MAPI) GroupWise messages addressed to personal groups.
The draft items are beginning to appear in users' mailboxes after the GroupWise client is updated to 5.5.1 or later. The "sudden" appearance of these draft items is due to fix that was made to the GroupWise Message Store Provider. Previously, it wasn't sending the "problem" messages (queued in the user database as described above) to the MAPI Spooler. Those System Administrator messages should have been delivered immediately upon having a problem. Now that the problem has been resolved, the new GroupWise Message Store Provider is starting to clear out the outgoing queue. Remember, it only does this upon request by the MAPI Spooler; therefore, the users are seeing these System Administrator messages after using MAPI to send a message (i.e., doing a FILE | SEND from Microsoft Word). Since the MAPI Spooler is not running long enough during a "FILE | SEND" from Word, it is unable to completely clear out the old queued up "System Administrator" messages; thus, users will continue to see those draft messages appear in their mailboxes until the queue has been cleared.
fix
This is fixed in the GroupWise 5.5 service pack 3 Client and the GroupWise 5.5 Enhancement Pack Client.
The updated GroupWise Client contains two files that fix messages being stored in the MAPI spooler and sent at a later date as a Draft message and addressed from System Administrator.
This was a previous workaround:
The current workaround is to run the Exchange client against the GroupWise message store. Let it sit for about 30 minutes to give the MAPI Spooler enough time to clear out the backed up queue. The MAPI Spooler will make a request for outgoing items every 60 seconds. The other workaround is to just let the queue clear over time as users send MAPI messages.
Troubleshooting Notes:
Steps to duplicate the problem have been as follows:
METHOD 1:
UserA sends an email (hereafter known as the "Original Email") to various users (hereafter known as the Original Users). Some time later (hours, days, weeks, or months) UserA receives an email from "System Administrator" with a draft item icon (pencil).
METHOD 2:
One site has duplicated what could be the same or similar error by using Microsoft's Internet Explorer 4.x and choosing File | Send | Page By Email. If GroupWise is not open, a prompt is received to choose a profile; at that point a GPF occurs followed by the appearance of a new GroupWise Send Message dialogue box. Before typing anything else:
1. The user will see a draft message in the mailbox. Once the message is sent, the draft message disappears.
2. Other messages from System Administrator like the one mentioned above that correspond to messages sent to users at some time in the past may appear in the mailbox.
METHOD 3 (most reliable):
1. Create a personal group (group may contain internal and/or external addresses)
2. Send a message to the personal group
3. Invoke MAPI by performing a File | Send from some MAPI enabled application (tested in-house with WordPad and Internet Explorer)
document
Document Title: | Draft Messages from "System Administrator" are appearing in users' mailboxes. |
Document ID: | 10016805 |
Solution ID: | 1.0.14740959.2323714 |
Creation Date: | 16Sep1999 |
Modified Date: | 24Jan2003 |
Novell Product Class: | Groupware |
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