How to troubleshoot Btrieve error messages.

(Last modified: 10Oct2000)

This document (10015295) is provided subject to the disclaimer at the end of this document.

goal

How to troubleshoot Btrieve error messages.

fact

Novell ManageWise 2.1

Novell ManageWise 2.6

Formerly TID 2931506

symptom

Error: "LDINV.DLL Please update btrieve (requester and DLLs to v6.1)"

    Error occurs when opening the Segment map.

Error: "OLF-INTRODUCER: Problem encountered in opening database: 153 invalid transaction filename."

    Error occurs when attempting to install ManageWise 2.1 on a NetWare 4.1 server. About 85% of the way through the console installation.

Error: "OLF-INTRODUCER: Problem encountered in opening database: 122. Database version mismatch detected."

Error: "Database Manager Type Mismatch 122."

    Error occurs when trying to open the database administration tool.

Error: "Read Write Error 002."

    Error occurs when the ManageWise application is opening.

Error: "OLF INTRODUCER: Problem encountered in opening database Database Unknown Error. "

    Error occurs during install of MW 2.1 on top of already installed MW 2.1.

Error: "N-snoopr.dll is not compatible with N-shell."

    Error occurs when the ManageWise 2.1 Console on a Windows for Workgroups PC or a Windows 95 machine starts up.

Error: "Invalid string ID 426 in printmessa."

    Error occurs when attempting to access desktop manager.

Error: "Problem encountered in opening database: 002 - An error occurred during disk read/write."

    Error occurs during the ManageWise 2.1 Console installation, at 85% the following message is returned.

cause

Typically, we find that there are several instances of WBTR*.* files throughout the drive; more specifically there are newer versions of WBTRCALL.DLL and other WBTR files in the WINDOWS directory, but the DLLs in the SYSTEM directory are the ones being used, and they are usually much older.

fix

Delete or rename all WBTR*.* files in the C:\WINDOW\SYSTEM directory. If you choose to rename the file, it may be necessary to change the leading character of the file instead of the file extension.

EXAMPLE: REN C:\WINDOWS\SYSTEM\WBTRCALL.DLL aWBTRCAL.DLL.

After renaming and/or deleting the WBTR*.* files in SYSTEM and consolidating them all to WINDOWS directory, then shutting down the machine and restarting, the problem goes away. Any of the following files may be applicable to these scenarios.

    WBT32RES.DLL
    WBTR32.EXE
    WBTRCALL.DLL
    WBTRLOCL.DLL
    WBTRVRES.DLL

document

Document Title: How to troubleshoot Btrieve error messages.
Document ID: 10015295
Solution ID: 4.0.38178137.2294657
Creation Date: 27Aug1999
Modified Date: 10Oct2000
Novell Product Class:Connectivity Products
Management Products
NetWare

disclaimer

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