Error: DS audit file is full for O=.

(Last modified: 03Jul2003)

This document (10015117) is provided subject to the disclaimer at the end of this document.

fact

Formerly TID 2952781

Novell NetWare 5.0

Auditing has not been enabled.

symptom

Error: DS audit file is full for O=<Organization Name>.

Error: Auditing file is full, volume auditing

Users can not login or map to the server.

cause

If volume auditing is turned on, and Audit DS events has been selected, when the file becomes full, it will stop all DS events including mapping or logging in to the server, regardless of SYS volume space.  Since the file is full, and users cannot login, AUDITCON cannot be started in order to disable Auditing.  There is NOT a good solution.  The only options are to delete the SYS volume and recreate it, or obtain a copy of a disk editor that can edit HEX to remove the auditing file.

fix

The following information (Solution One or Solution Two) may work for container auditing as long as auditing can be turned off.

SOLUTION ONE:

Run SYS:PUBLIC\AUDITCON.EXE at a workstation.
    1) Select  DS | Enable Auditing.
    2) Select File Maintenence | Reset
    3) Return to DS and Disable Auditing.

If this does not solve then problem then prepare for dial-in and follow these steps:

*Note:  If more than one server is getting DSAudit file errors, you may need to lock the databases on all the servers as you make changes.

Close the database.
Using NETBASIC, JCMD or Compaq File Manager, Look in the SYS:_NetWare directory for all *.$* files (ex:710000C4.$AF) and the net$audt.caf file.
Erase all the *.$*  files.
Erase the net$audt.caf file.

Reload DS on all servers.

SOLUTION TWO:

Assume:
Server 1 = holds a R/W replica and is not having the auditing file problem.
Server 2 = holds a Master replica and IS having the auditing file problem.
Server 3 = holds a R/W replica and IS having the auditing file problem.

1.  On ALL servers run DSRepair | Report Sync Status and verify that there are no errors.
2.  Promote the Server 1 to be the new MASTER  (the server with no problems) - wait until all servers show Server 1 as the Master. (the master replica needs to be on a server not experiencing the auditing file problem, or new replicas added to servers may also have the problem.
3.  In NDS Manager, remove the replica from Server 3
4.  Bounce Server 3 (down and restart the server)
5.  Place a new R/W replica on Server 3
6.  Repeat Steps 3-5 for Server 2.
7.  After a health check is performed (TID10060600) successfully, move the MASTER back to server 2.

document

Document Title: Error: DS audit file is full for O=<Organization Name>.
Document ID: 10015117
Solution ID: 4.0.34856156.2291529
Creation Date: 25Aug1999
Modified Date: 03Jul2003
Novell Product Class:End of Life
NetWare
Novell eDirectory

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.